Ask Your Question
1

DevStack Installation issues

asked 2015-11-03 17:40:16 -0500

Nicam Energy gravatar image

Has anyone been able to install and configure DevStack?

STEP 1: git clone https://git.openstack.org/openstack-dev/devstack (https://git.openstack.org/openstack-d...)

STEP 2: run not using "root". I have tried to install this software on several brand new VMs from RedHat 5.xx to 6.xx from Ubuntu 12.xx to 14.xx as mentioned in your documentation . . . you have no idea about the plethora of errors.

Missing this missing that, do this do that, change this modify that . . . .. bla bla bla bla bla bla bla bla . . . . nothing worked.

Do I need any magic wand?

edit retag flag offensive close merge delete

Comments

Hello, I'm on the same boat.

Please see https://ask.openstack.org/en/question/84519/devstack-installation-cinder-db-sync-error-keyword-argument-max-on-opt-library-wrong/ (link text)

Mine seems to be a code problem (API as method does not accept more parameters). Git repository should need a clean up.

Halflernation gravatar imageHalflernation ( 2015-11-13 04:02:07 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2017-02-24 04:58:30 -0500

Shaik Saddam Hussain gravatar image

Hi,

I have tried building OpenStack AIO(All in One) Setup and it was successful on VMware hypervisor and KVM hypervisor.

It is very simple ultility to get OpenStack deployed, you just need to run few commands and few changes in editing file and rest of the work will be taken care by devstack utility.

Please refer to this link for your reference.

https://docs.openstack.org/developer/devstack/guides/single-machine.html (https://docs.openstack.org/developer/...)

Note: OpenStack needs to be deployed from Non-root user with root privilages.

edit flag offensive delete link more
1

answered 2016-02-01 19:28:30 -0500

victorx gravatar image

I was able to install DevStack stable/liberty on a Ubuntu 14.04.03 Trusty VM on VMware player. On Step 1 above, try to git clone stable/liberty rather than the master branch. The master branch gave me errors but the stable/liberty installed smoothly. I used my own ID with sudo.

edit flag offensive delete link more
0

answered 2017-02-28 11:15:23 -0500

Seems like you are trying to install this over Redhat.

Installing Vagrant on your local should be pretty straight forward http://www.installvirtual.com/install-vagrant-on-centos-7/ (http://www.installvirtual.com/install...) https://jonathansblog.co.uk/installing-vagrant-on-centos-7 (https://jonathansblog.co.uk/installin...)

Once you have that, ssh into the vagrant box, then do a clone of devstack repository.

Set the local.conf file with the desired services which you want in your openstack ex. https://docs.openstack.org/developer/horizon/ref/local_conf.html (https://docs.openstack.org/developer/...)

Then just simply do a ./stack.sh and you should be good to go.

edit flag offensive delete link more
0

answered 2017-02-28 11:33:11 -0500

electrocucaracha gravatar image

Well, this is my vagrant devstack deployment script[1], so I haven't face with that problem because I use vagrant user as a devstack user, but if you need to create a new user for devstack you can use this script[2] to do it

[1] https://github.com/electrocucaracha/v... [2] https://github.com/openstack-dev/devs...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-03 17:40:16 -0500

Seen: 656 times

Last updated: Feb 28 '17