i am not able to login to dashboard with my host ip,it is displaying err_connection timed out(webpage is not available).what could be the problem?

asked 2015-11-03 09:41:46 -0600

Nitesh gravatar image

using ubuntu 14.04 trusty lahr in virual box with windows 7

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-11-03 14:41:19 -0600

updated 2015-11-06 12:01:58 -0600

It sounds like your apache is not running. Try:

service apache2 status

Also, make sure it is listening on port 80, by:

netstat -tulpen


It sounds like your devstack did not install properly the dashboard. I also tried to devstack back in the days, and also run into some problems, but finally I found it easier to deal with the OpenStack install guide rather than the devstack installer.

If what you want is just to get the OpenStack installed and play around a little bit, I strongly recommend you to give a try to the installer I wrote. It can create 3 (or more) virtual machines, 1 for controller, 1 for neutron node and 1 as a compute node, and install everything following the docs.openstack.org install guide for CentOS7/Kilo step by step.

You can try it from your Ubuntu machine just by:

   sudo apt-get update
   sudo apt-get -y install git 
   git clone https://github.com/julenl/BOMSI.git
   cd BOMSI/CentOS7-Kilo
   for NODE in controller network compute1; do ./bomsi-iso.sh -n=$NODE; done

It will take a while (some 10 minutes or so), because it has to download a CentOS image and install all the packages for KVM. But well, after this, just go to on a browser and log in with:

user: admin
password: Password

... and start launching instances :)

If you have any problems with it, let me know.

edit flag offensive delete link more


yes my apache is running,and port 80 is also listening,,but still no success!!

Nitesh gravatar imageNitesh ( 2015-11-04 05:37:24 -0600 )edit

Did you check for errors in the apache logs? If apache is running and listening on the port 80 (not blocked by the firewall), in principle you should get something on the browser... I am also assuming that you installed all the rest of the components, like keystone, dashboard, ... right?

Julen Larrucea gravatar imageJulen Larrucea ( 2015-11-04 06:57:57 -0600 )edit

yes i installed all the components ,keystone is working good,how can i check the errors in apache logs?i am beginner with linux and openstack actually!^.^

Nitesh gravatar imageNitesh ( 2015-11-04 07:06:41 -0600 )edit

can you post with the commands sir???thanks

Nitesh gravatar imageNitesh ( 2015-11-04 07:13:28 -0600 )edit

Errors in apache:

 grep ERROR /var/log/apache2/error.log

Check what is listening on port 80:

 telnet MACHINE_IP  80

Check that you really installed the rest of the services:

 ls /etc/keystone  /etc/nova  /etc/openstack-dashboard

What's the result of them?

Julen Larrucea gravatar imageJulen Larrucea ( 2015-11-04 09:49:18 -0600 )edit

answered 2015-11-05 07:09:04 -0600

Nitesh gravatar image

updated 2015-12-18 16:54:53 -0600

git clone https://github.com/julenl/BOMSI.git
cd BOMSI/CentOS7-Kilo
chmod +x custom-iso.sh
for NODE in controller network compute1; do ./bomsi-iso.sh -n=$NODE; done

i used this code as well as corrected one by { touch custom-iso.sh } line before the (chmod +x...etc)..but for the ./bomsi-iso.sh -n=$NODE ,it says -bash:permission denied. thanks.

edit flag offensive delete link more


i sorted out this permission denied problem by using command:::chmod 500 bomsi-iso.sh,,,,this give me the permission to access the file and then i executed the last set of commands i.e ./bomsi-iso.sh -n=$NODE,,and it starts executing..

Nitesh gravatar imageNitesh ( 2015-11-05 11:19:11 -0600 )edit

well now it is giving error::operation failed : network storage is already exist with uuid cf6/....etc||| error::failed to start network storage.|||internal error::network is already in use by eth0. |||/home/user/bomsi/centos7-kilo/bomsi_lib_vm:line 244 :command not found???thanks till now

Nitesh gravatar imageNitesh ( 2015-11-05 11:32:55 -0600 )edit

I just updated the code with a few little fixes. Try again from the beginning. If unsure, also remove all the virtual networks with "sudo virsh net-undefine storage" and so on

Julen Larrucea gravatar imageJulen Larrucea ( 2015-11-05 11:58:50 -0600 )edit

please can you send me the steps you followed for configuring keystone dashboard

vibhu gravatar imagevibhu ( 2015-12-18 05:49:50 -0600 )edit

you mean, for configuring keystone using BOMSI? It does everything for you already... Run the script and if you want to check what it does, check the /etc/init.d/firstrun_controller file on the controller node. You'll find the "controller_bund" function, search for it on bomsi_lib_conf

Julen Larrucea gravatar imageJulen Larrucea ( 2015-12-18 16:51:45 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-11-03 09:41:46 -0600

Seen: 737 times

Last updated: Dec 18 '15