Ask Your Question
0

VMware static IP configuration using Nova FlatManager

asked 2015-11-02 14:27:18 -0500

wittjr gravatar image

I have OpenStack Kilo running on Ubuntu 14.04.3, configured following the instructions at http://docs.openstack.org/kilo/install-guide/install/apt/content/ (http://docs.openstack.org/kilo/instal...). Everything seems to work OK except for communication with the guest OS. The main issue is that the static IP is not getting set correctly. Horizon lists an IP in my network associated with the guest but the guest is using an address from our network DHCP pool. When viewing the instance details in horizon I can not see the console log nor the vnc console for the guest. I'm trying to use the Nova network with FlatManager.

Anyone know what the issue might be or where I might check? I'm out of ideas.

Below is my nova.conf for reference.

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
debug=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
auth_strategy = keystone
my_ip=192.168.x.x
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 192.168.x.x
novncproxy_base_url = http://oscontrol:6080/vnc_auto.html
network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatManager
network_size = 254
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth0
public_interface = eth0
compute_driver=vmwareapi.VMwareVCDriver
force_config_drive = always
flat_injected = True

[glance]
host = oscontrol

[oslo_concurrency]
lock_path = /var/lib/nova/tmp

[keystone_authtoken]
auth_uri = http://oscontrol:5000
auth_url = http://oscontrol:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = PASSWORD

[oslo_messaging_rabbit]
rabbit_host = oscontrol
rabbit_userid = openstack
rabbit_password = PASSWORD

[database]
connection = mysql://nova:PASSWORD@oscontrol/nova

[vmware]
host_ip=192.168.x.x
host_username=admin
host_password=PASSWORD
cluster_name=Cluster
datastore_regex=DS.*
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-03 09:22:48 -0500

ktibi gravatar image

We use neutron for Vmware. (No need NSX)

But I guess your pb is a communication pb. Try to console in your VM by Vsphere and add an IP.

After that, try to ping your DHCP IP. You can see this ip on your network node with "ip netns exec DHCPID ifconfig".

If ping is OK it's your vm which not in DHCP MODE.

edit flag offensive delete link more

Comments

I didn't think Neutron could assign a static IP for VMware guest systems?

The system works with DHCP. I can ping and SSH into the guest. Unfortunately the guest customization should be modifying the interface from the default of DHCP to use a static IP and that doesn't seem to be happening.

wittjr gravatar imagewittjr ( 2015-11-03 13:01:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-11-02 14:27:18 -0500

Seen: 104 times

Last updated: Nov 03 '15