Neutron LBaaS issue after upgrading to Liberty. 'NoneType' object has no attribute 'rpartition'

asked 2015-11-02 08:38:04 -0500

Xavier gravatar image

updated 2015-11-03 09:32:30 -0500

Hello,

I've upgrade my plateforme to Liberty (Ubuntu 14.04 LTE). Since then I get thousands of errors into ==> /var/log/neutron/neutron-lbaas-agent.log <==

CRITICAL neutron [req-4d9c511e-576e-4573-82f8-daf35f6ffc86 - - - - -] AttributeError: 'NoneType' object has no attribute 'rpartition'
ERROR neutron Traceback (most recent call last):
ERROR neutron   File "/usr/bin/neutron-lbaas-agent", line 10, in <module>
ERROR neutron     sys.exit(main())
ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/services/loadbalancer/agent/agent.py", line 61, in main
ERROR neutron     mgr = manager.LbaasAgentManager(cfg.CONF)
ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/services/loadbalancer/agent/agent_manager.py", line 70, in __init__
ERROR neutron     self._load_drivers()
ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/services/loadbalancer/agent/agent_manager.py", line 95, in _load_drivers
ERROR neutron     self.plugin_rpc
ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_utils/importutils.py", line 38, in import_object
ERROR neutron     return import_class(import_str)(*args, **kwargs)
ERROR neutron   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 71, in __init__
ERROR neutron     vif_driver = importutils.import_object(conf.interface_driver, conf)
ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_utils/importutils.py", line 38, in import_object
ERROR neutron     return import_class(import_str)(*args, **kwargs)
ERROR neutron   File "/usr/lib/python2.7/dist-packages/oslo_utils/importutils.py", line 26, in import_class
ERROR neutron     mod_str, _sep, class_str = import_str.rpartition('.')
ERROR neutron AttributeError: 'NoneType' object has no attribute 'rpartition'

Does any one have a clue on this issue ?

Xavier

edit retag flag offensive close merge delete

Comments

I also experience the same problem on OpenStack Liberty when I try to setup LBaaS agent in Neutron

Clarence gravatar imageClarence ( 2015-11-24 02:10:17 -0500 )edit
1

Hi there. You do not have interface_driver config in your configuration file.

hunters1094 gravatar imagehunters1094 ( 2015-12-15 03:43:14 -0500 )edit