Ask Your Question
0

Heat-engine is not starting

asked 2013-12-10 06:48:24 -0500

joshua gravatar image

updated 2013-12-10 11:26:15 -0500

dheeru gravatar image

Heat Engine failed start. I see the following exception in the logs. Can somebody help on this ?

Error seen in log

2013-12-09 00:41:00.313 24332 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-09 00:41:00.313 24332 TRACE heat
2013-12-09 00:46:20.326 25598 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-09 00:46:20.326 25598 TRACE heat Traceback (most recent call last):
2013-12-09 00:46:20.326 25598 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-09 00:46:20.326 25598 TRACE heat     db_api.configure()
2013-12-09 00:46:20.326 25598 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-09 00:46:20.326 25598 TRACE heat
2013-12-09 15:37:52.538 15436 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-09 15:37:52.538 15436 TRACE heat Traceback (most recent call last):
2013-12-09 15:37:52.538 15436 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-09 15:37:52.538 15436 TRACE heat     db_api.configure()
2013-12-09 15:37:52.538 15436 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-09 15:37:52.538 15436 TRACE heat
2013-12-09 16:08:49.892 23123 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-09 16:08:49.892 23123 TRACE heat Traceback (most recent call last):
2013-12-09 16:08:49.892 23123 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-09 16:08:49.892 23123 TRACE heat     db_api.configure()
2013-12-09 16:08:49.892 23123 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-09 16:08:49.892 23123 TRACE heat
2013-12-10 13:21:26.058 15213 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-10 13:21:26.058 15213 TRACE heat Traceback (most recent call last):
2013-12-10 13:21:26.058 15213 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-10 13:21:26.058 15213 TRACE heat     db_api.configure()
2013-12-10 13:21:26.058 15213 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-10 13:21:26.058 15213 TRACE heat
2013-12-10 13:22:21.971 15942 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-10 13:22:21.971 15942 TRACE heat Traceback (most recent call last):
2013-12-10 13:22:21.971 15942 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-10 13:22:21.971 15942 TRACE heat     db_api.configure()
2013-12-10 13:22:21.971 15942 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-10 13:22:21.971 15942 TRACE heat
2013-12-10 13:25:53.650 16784 CRITICAL heat [-] 'module' object has no attribute 'configure'
2013-12-10 13:25:53.650 16784 TRACE heat Traceback (most recent call last):
2013-12-10 13:25:53.650 16784 TRACE heat   File "/usr/bin/heat-engine", line 65, in <module>
2013-12-10 13:25:53.650 16784 TRACE heat     db_api.configure()
2013-12-10 13:25:53.650 16784 TRACE heat AttributeError: 'module' object has no attribute 'configure'
2013-12-10 13:25:53.650 16784 TRACE heat ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-12-11 00:07:30 -0500

dheeru gravatar image
This is happening when you service is creating db access. By looking at the symptom you posted and source code of heat I suggest you to do the following.

1. Can you check your db configuration ?
2. Drop the heat db and re-create the heat db.

This may solve your problem.
edit flag offensive delete link more
0

answered 2014-01-06 00:48:57 -0500

DennyZhang gravatar image

updated 2014-01-06 00:49:35 -0500

Installing and configuring heat is re-entrant.

Try the following the procedure, and make sure every step is truly correct. Then your heat environment may be fine then.

http://docs.openstack.org/havana/install-guide/install/yum/content/heat-install.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-10 06:48:24 -0500

Seen: 579 times

Last updated: Jan 06 '14