Ask Your Question
0

how to attach openstack dash-board ip address to public ip address? [closed]

asked 2015-10-30 07:03:50 -0500

cloudlearner gravatar image

I want to access my dash-board via public ip address. Now dashboard is accessed by 192.168.10.3/dashborad locally on LAN. i add the public ip ALLOWED_HOST=[124.X.X.X] in /etc/openstack-dashboard/local_setting and i aslo cahnged ip address on controller and compute node novncproxy_base_url=http://192.168.10.3:6080/vnc_auto.html in nova.conf to novncproxy_base_url=http://124.X.X.X:6080/vnc_auto.html . Now the service novcnproxy become dead, and not able to access dash-board via public ip. Plz suggest now where i have done mistake or any other changes should be made.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by cloudlearner
close date 2015-11-02 23:35:50.521604

Comments

First of all: does this machine (system) have public IP, reachable from outside?

rozie gravatar imagerozie ( 2015-10-30 08:43:53 -0500 )edit

i have map local ip to public ip on the firewall. if access dashboard via public ip the page is unavailable.

cloudlearner gravatar imagecloudlearner ( 2015-11-01 22:04:34 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-02 00:22:53 -0500

cloudlearner gravatar image

problem solved, now dashboard is accessed by public ip, actually novncproxy was creating the problem it became dead after reinstalling the the novncproxy again it is working fine

edit flag offensive delete link more
0

answered 2015-10-30 19:54:14 -0500

MIB gravatar image

Hi,

Why don't you do a NAT with your current 192.168.10.3 IP.

edit flag offensive delete link more

Comments

because the novncproxy_base_url need to be setup ;)

Xavier gravatar imageXavier ( 2015-11-02 08:46:11 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-30 07:03:50 -0500

Seen: 618 times

Last updated: Nov 02 '15