Ask Your Question
0

How to configure multi-node w/ single-nic?

asked 2015-10-28 17:06:22 -0600

stindell gravatar image

Struggling to get this running. 1 Controller, 1 Network, 1 Compute.

Here are my ml2.ini configs, ovs-vsctl show output, and ovs-ofcs dump-flows output: http://pastebin.com/wCNj4iUK

Everything seems to work except for my GRE tunnel.

Can you tell me where I am going wrong with my table rules? Or give me some tips on how to get this setup going?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-28 23:42:14 -0600

ritesh.singh.aricent@gmail.com gravatar image

Installation guide clearly tells we need to maintain two interface like eth0 & eth1. eth0 for management network and eth1 for tunnel network. i hope you need to do the same thing. To debug and understand you can follow - https://www.hastexo.com/system/files/....

I have done this using VLAN type set up, where I have assigned IP to bridge , so that I can have both , data and management network on same NIC.

Please check- https://ask.openstack.org/en/question...

edit flag offensive delete link more
0

answered 2015-10-29 03:09:10 -0600

dbaxps gravatar image

You can use same Ethernet interfaces for Mgmt Network and GRE(VXLAN) tunnel endpoints.
No problems in regards of POC setup. It's performance issue having nothing in common with
functionality of system in general. Been setup in production it might result unacceptable network
congestion.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-28 17:06:22 -0600

Seen: 555 times

Last updated: Oct 29 '15