Ask Your Question
0

Failed to change power state to 'power on'. Error: Failed to connect to AMT service.

asked 2015-10-28 01:25:30 -0500

Afaque gravatar image

Hello,

I am trying to provision bare metal Intel Hardware using ironic service (with pxe_amt driver). I have enrol a node and try to switch power state by command- $ironic node-set-power-state $NODE_UUID on after, I am checking nova node-show by command- $ironic node-show $NODE_UUID

And got error like- last_error | Failed to change power state to 'power on'. Error: Failed to connect to AMT service.

I would like to know the reason Failed to connect to AMT service. i have installed openwsman.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-09 11:27:33 -0500

Afaque gravatar image

updated 2015-12-09 11:28:12 -0500

Problem resolved by updating Openwsman lib.

find the link to update openwsman lib for different Linux families-

http://software.opensuse.org/download.html?project=Openwsman&package=openwsman (http://software.opensuse.org/download...)

For Centos follow these steps- cd /etc/yum.repos.d/ wget http://download.opensuse.org/repositories/Openwsman/Fedora_22/Openwsman.repo (http://download.opensuse.org/reposito...) yum install openwsman

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-28 01:15:35 -0500

Seen: 734 times

Last updated: Dec 09 '15