Ask Your Question
0

Cannot Ping VMs

asked 2015-10-27 14:24:56 -0600

stindell gravatar image

updated 2015-10-27 14:33:10 -0600

I have 3 physical hosts:

controller 10.0.0.111

network 10.0.0.113

compute1 10.0.0.114

Each has only 1 NIC.

OpenStack Kilo, KVM.

I have setup the keystone, glance, and nova services. I have configured neutron with openvswitch and gre tunnels. Yesterday I setup neutron services, configured my ml2 plugin files, and started up an instance. I was able to create networks/subnets, and a router attached to the appropriate networks. I can ping the router. The router and dhcp server can ping each other. But they cannot ping my VMs. I assume it's a problem with the br-int and br-tun between network <-> compute nodes.

Here are my ml2.ini configs, ovs-vsctl show output, and ovs-ofcs dump-flows output: http://pastebin.com/wCNj4iUK

Here's my VM: | 2b135380-6218-43da-9fe2-08d8e5ee58c7 | demo-instance1 | ACTIVE | - | Running | demo-net=192.168.1.3, 10.0.0.120 |

In the virtual machine console log, it shows that it is not getting a DHCP lease at all. Starting network... udhcpc (v1.20.1) started Sending discover... Sending discover... Sending discover... Usage: /sbin/cirros-dhcpc <up|down> No lease, failing WARN: /etc/rc3.d/S40-network failed

IPTables is disabled on all hosts.

There is no br-tun interface to tcpdump on the compute node. tcpdump on the br-int interface qvo1351e4f4-d2 shows nothing when I try to ping from network host -> VM or from qrouter -> VM.

Any tips? Any idea where my network setup has gone wrong?

edit retag flag offensive close merge delete

Comments

Installation guide clearly tells we need to maintain two interface like eth0 & eth1. eth0 for management network and eth1 for tunnel network. i hope you need to do the same thing.

To debug and understand you can follow - https://www.hastexo.com/system/files/neutron_packet_flows-notes-handout.pdf (https://www.hastexo.com/system/files/...)

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-27 22:49:55 -0600 )edit

I only have one NIC per host. What do you suggest?

stindell gravatar imagestindell ( 2015-10-28 13:12:24 -0600 )edit

well, that's tricky then , we need a workaround , I have done this for vlan based network where i have created a bridge (eg- br-eth) on the NIC and provided the Management IP to that bridge. So eventually , you will have the bridge to connect to br-int and also an IP for management network.

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-28 23:30:39 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-12-28 18:22:38 -0600

tze gravatar image

First of all i think Some versions of Cirros Image has a bug with DHCP leases. Check if your Image version hasn't bug on DHCP lease. Secondly i think your gre setup is ok. On your both nodes (Network and compute) you have from one internal port so, you can add a temporarly ip (other subnet of that you already used) on both interfaces (Network node/br-tun, Compute node/br-tun) and check if they can ping each other. If your ping works, your gre tunnel is correct. I need more details to suggest you something else, for example the neutron networks config, and subnet confg. You Dhcp agent works fine(openstack network agent list)? On network node the network namespace created correct?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-27 14:24:56 -0600

Seen: 286 times

Last updated: Dec 28 '16