Ask Your Question
1

install apache on openstack instance

asked 2013-12-09 18:23:06 -0500

xuelinlin88 gravatar image

Hi,

I installed apache (set listen to be 3972) on openstack instance and modified httpd.conf accordingly. I also installed apache on my openstack host, with port 3973 However, it failed if I tried to type "http://instancename:3972/". If I typed "http://instancename:3973/", it is working. But, actually, it is working not because of instance apache. Instead, it is still pointing to the host apache. Therefore, that apache welcome page still came up even if I type another instance name with port 3973.

I'm wondering how can i make my instance apache work. Because I'm planning to install other app on the instance, I need to make sure I can visit that service via instance floating ip, instead of hosting ip.

Do i need to specify a port on host to that instance apache port?

Lynn

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-10 03:35:59 -0500

mrunge gravatar image

Did you add a security rule for that port?

edit flag offensive delete link more

Comments

hi, I only added tcp 22 and icmp -1 to my security rule. So whenever I want to use any port in openstacn instance, I need to add it to security rule first? it should be tcp, icmp or udp? I'm thinking sth needs to be setting, so that outside can visit instance web service. But no idea what and how to do it. Thanks Lynn

xuelinlin88 gravatar imagexuelinlin88 ( 2013-12-10 08:44:41 -0500 )edit

Yes, in order to enable traffic to be forwarded to your instance, you need to add it to your security rule, like you did tcp 22 and icmp -1

mrunge gravatar imagemrunge ( 2013-12-17 03:23:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-12-09 18:23:06 -0500

Seen: 595 times

Last updated: Dec 10 '13