Ask Your Question
2

service cinder-volume ubuntu@lmdriver-1 problem

asked 2015-10-25 10:18:25 -0500

openstack_single_node_saas gravatar image

Hi Everybody,

I installed Openstack using Devstack on a single machine running Ubuntu 14.04.2 Server. When I reboot the machine, I run rejoin-stack.sh. Apparently all services come back except that Storage information cannot be retrieved on dashboard. Also the following message is repeatedly displayed on the console:

Error: cinder.service (-) Manager for service cinder-volume ubuntu@lmdriver-1 is reporting problem, not sending heartbeat, service will appear down

I would greatly appreciate if someone could help me solve this problem.

Thanking you in anticipation.

Best regards,

Hamid Sultan

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
3

answered 2015-10-25 10:38:55 -0500

dbaxps gravatar image

Run script ( ahead of rejoin_stack.sh ):-

# cp stack-volumes-default-backing-file /opt/stack/data/stack-volumes-default-backing-file
# cp stack-volumes-lvmdriver-1-backing-file /opt/stack/data/stack-volumes-lvmdriver-1-backing-file
sudo losetup /dev/loop0 /opt/stack/data/stack-volumes-default-backing-file
sudo losetup /dev/loop1 /opt/stack/data/stack-volumes-lvmdriver-1-backing-file

If mentioned files exist losetup would be enough, if no, then rerun ./stack.sh , copy them to your $HOME dir
and uncomment two first lines.

edit flag offensive delete link more

Comments

Hi Boris,

Please let me know if I understand your suggestion clearly:

When I run the last two lines (from above commands) there is no mention of files existing. Then I run stack.sh again Then I copy the above four line script into /home/stack folder

Please correct me if I am wrong

Thanks Hamid

openstack_single_node_saas gravatar imageopenstack_single_node_saas ( 2015-10-27 01:42:41 -0500 )edit

If files still exist under /opt/stack just losetup is enough, if they are gone you need reinstall (./stack.sh ) and save them ( for example in $HOME ), because you will need restore them from $HOME location before rejoin_stack.sh

dbaxps gravatar imagedbaxps ( 2015-10-27 04:48:56 -0500 )edit

Hi Boris,

Thank you so much for your help. I followed your suggestion and it works. Thanks again. Best regards,

Hamid Sultan

openstack_single_node_saas gravatar imageopenstack_single_node_saas ( 2015-11-02 08:45:55 -0500 )edit

@dbaxps Thanks for the hint. Same issue with Queens release on F27 In my case the files /dev/loop0 and /dev/loop1 was not present. So created both of them and executed the commands mentioned by you..restarted the c-vol service. I am able to create cinder volumes. So posting it as answer.

rackerstacker gravatar imagerackerstacker ( 2018-02-23 06:55:50 -0500 )edit
0

answered 2016-07-05 16:54:25 -0500

Gaurav Goyal gravatar image

I have installed liberty and integrated it with ceph storage. I am also facing the same issue for volume. please help me on this.

edit flag offensive delete link more
0

answered 2018-02-23 07:00:52 -0500

rackerstacker gravatar image

updated 2018-02-23 07:06:39 -0500

Fix for Queens Release on F27.. Check if /dev/loop0 and /dev/loop1 is already created or not. If not execute the below commands:

[root@localhost ~]# losetup -f
/dev/loop0 
[root@localhost ~]# sudo losetup /dev/loop0 /opt/stack/data/stack-volumes-default-backing-file
[root@localhost ~]# losetup -f
/dev/loop1
[root@localhost ~]# sudo losetup /dev/loop1 /opt/stack/data/stack-volumes-lvmdriver-1-backing-file
[root@localhost ~]# systemctl restart devstack@c-vol.service

Cheers !!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-25 10:18:25 -0500

Seen: 4,559 times

Last updated: Feb 23 '18