Ask Your Question
1

Windows 8 x86 on Grizzly

asked 2013-12-09 15:22:26 -0500

ghost gravatar image

I'm seeing an issue with Windows 8 x86 specifically. I'm running an Openstack Grizzly environment with KVM as the hypervisor. When I create a new instance from the Openstack UI and mount a Windows 8 x86 ISO, I get the following error at boot:

"Your PC needs to restart. Please hold down the power button. Error Code: 0x0000005D Parameters: 0x03062A01 0x756E6547 0x49656E69 0x6C65746E"

After googling this it seems to be a CPU error but what confuses me is when I load a Windows 8 x64 ISO I do not see this problem and it boots to the Windows 8 x64 installer.

Any ideas why this is happening and how I can fix it? Also is there a way to set default parameters for created instances? For example if I want every machine that gets created to have an IDE hard drive, can I configure something to allow that?

Thanks. -ghost

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-10 21:37:03 -0500

sigrist gravatar image

Hi ghost!

I think I know what may be happening to you, I had the same happen to me with Windows Server 2012.

You probably haven't configured the CPU model in your compute node (nova-compute.conf) so by default KVM is basically advertising all your host's processor capabilities to the guest, even those that KVM itself doesn't support.

So Windows attempts to execute an instruction that the guest processor doesn't support, which causes the invalid instruction processor exception, which then leads to your STOP 0x5D.

To fix it, try this. Assuming you have an Intel "Sandy Bridge" CPU model on your host, add those lines to your nova-compute.conf, which will configure the guest-exposed CPUs as that model. When you configure explicitly, KVM doesn't expose to the guest instructions that it doesn't support:

libvirt_cpu_mode=custom
libvirt_cpu_model=SandyBridge

For more information on those settings, check this out: https://wiki.openstack.org/wiki/LibvirtXMLCPUModel

Cheers, and let us know how that goes, if that solves your problem etc!

-- thiago

edit flag offensive delete link more

Comments

1

Thank you for the response thiago, unfortunately it is still not working for me though. I am using RedHat KVM as the underlying hypervisor on the nova compute node and after looking at the RedHat virtualization guest os support matrix, I don't see Windows 8 on there. So it seems to me that Windows 8 is not supported on KVM? Also what is weird is I don't have this 0x5D STOP error with Windows 8 x64 and Windows Server 2012, only with Windows 8 x86...

ghost gravatar imageghost ( 2013-12-12 10:16:44 -0500 )edit

Thanks man! I haven't tried x86 myself, only x64. Did you create a whole new instance after setting the libvirt CPU model? IIRC, changing CPU models will only affect new instances, not previously existing ones (because for them the libvirt XML will already have been created).

sigrist gravatar imagesigrist ( 2013-12-12 14:06:29 -0500 )edit

I would also try older CPU models... maybe one of them would work, IDK.

sigrist gravatar imagesigrist ( 2013-12-12 14:07:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-12-09 15:22:26 -0500

Seen: 548 times

Last updated: Dec 10 '13