redhat RDO enable access to swift via S3

asked 2015-10-23 06:17:40 -0500

dafridgie222 gravatar image

updated 2016-02-04 03:01:16 -0500

I'm running the latest RDO build and am having issues setting up S3 access.

It looks like the S3 middleware packages are present , but am having trouble setting up the proxy server to get it working.

I've setup proxy with these additional entries as follows:

use = egg:swift3#swift3

paste.filter_factory = keystonemiddleware.s3_token:filter_factory
auth_port = 35357
auth_host =
auth_protocol = http

also set

pipeline = catch_errors bulk healthcheck swift3 cache crossdomain ratelimit authtoken keystone staticweb tempurl slo formpost account_quotas container_quotas proxy-server

I cannot get a connection via any S3 client - (my use case is windows based s3 clients) Cyberduck, Cloudberry all have the same errors - access denied Ive en tried Dragondrive on linux without success - same problem

So i guess it must be what I'm using for access credentials, I've tried tenantname:username tenantid:ec2accesskey

so if someone can point me to exactly how to configure an S3 connection to openstack swift on RDO, I would really appreciate it

any guidance or feedback is really appreciated


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-08-18 13:38:57 -0500

rbowen gravatar image

The documentation for configuring an S3 connection to OpenStack Swift is here:

Unfortunately, this doc doesn't appear to exist in newer versions of the documentation (ie, with newton or mitaka on that URL rather than liberty)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2015-10-23 06:17:40 -0500

Seen: 411 times

Last updated: Aug 18 '16