Ask Your Question
0

Neutron: Can't ping external gateway

asked 2015-10-22 00:12:25 -0600

Allen Liu gravatar image

I am following "OpenStack Installation Guide for Ubuntu 14.04 -Kilo (June 8,2015)" to set up my first , minimum environment. I have 3 nodes -control, network, and compute1. Now I am at "Create Initial Network" after deployed Neutron on all 3 nodes. I need to verify network connectivity ( Page 90 in the doc).

The issue I have is that I cannot get response if I ping the demo-router gateway IP (172.16.11.22) from another machine on the same external network.

From the info below, seems "ifconfig" doesn't show enough interfaces.

Here is some set up info:

On network node

/etc/network/interfaces:

# The external network interface added
auto eth2
iface eth2 inet manual
        up ip link set dev $IFACE up
        down ip link set dev $IFACE down

# ovs-vsctl show

7c4d7ff1-8a18-4141-8033-b8fff7cb1056
    Bridge br-tun
        fail_mode: secure
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-c0a8006a"
            Interface "gre-c0a8006a"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.0.105", out_key=flow, remote_ip="192.168.0.106"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-a6c7603a-8e"
            Interface "qg-a6c7603a-8e"
                type: internal
    Bridge br-int
        fail_mode: secure
        Port "tapa895dd41-f6"
            tag: 1
            Interface "tapa895dd41-f6"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port "qr-16141141-56"
            tag: 1
            Interface "qr-16141141-56"
                type: internal
    ovs_version: "2.3.2"

# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:50:56:a2:5c:ec
          inet addr:10.6.117.174  Bcast:10.6.117.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fea2:5cec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2142 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2662 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:204161 (204.1 KB)  TX bytes:487972 (487.9 KB)

eth1      Link encap:Ethernet  HWaddr 00:50:56:a2:1f:a1
          inet addr:192.168.0.105  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fea2:1fa1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:637 errors:0 dropped:21 overruns:0 frame:0
          TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:46394 (46.3 KB)  TX bytes:14485 (14.4 KB)

eth2      Link encap:Ethernet  HWaddr 00:50:56:a2:60:44
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:333 errors:0 dropped:0 overruns:0 frame:0
          TX packets:333 errors ...
(more)
edit retag flag offensive close merge delete

Comments

Let me make the issue clearer. I should not say "can't ping external gateway". What I want to say is: In external subnet (In the IG doc, it is 203.0.113.0/24, IP range 101-200.), the router gateway (203.0.113.101) is not reachable from another external host located on 203.0.113.0/24 .

Allen Liu gravatar imageAllen Liu ( 2015-10-22 15:23:52 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-22 02:32:17 -0600

dbaxps gravatar image
edit flag offensive delete link more

Comments

Hi dbaxps,thanks for the info. I checked the above link you provided. I am confused: You told to use 192.168.1.XX IP addresses for br-ex in /etc/network/interfaces. In the example in the Installation Guide Kilo, this subnet is a tenant subnet, why br-ex use use an IP address in this subnet?

Allen Liu gravatar imageAllen Liu ( 2015-10-22 15:14:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-22 00:12:25 -0600

Seen: 1,782 times

Last updated: Oct 22 '15