Ask Your Question
0

cinder : ERROR (EndpointNotFound): publicURL endpoint for volume service not found

asked 2015-10-21 12:16:19 -0600

lgctelecom gravatar image

updated 2015-10-25 01:26:47 -0600

Hi

I'm deploying Openstack Liberty but i have some issues regarding Cinder configuration. Following official documentation making verifies suggested all is ok, im able to create volumes and im able to attache volumes to istance using CLI command, but first of all i cannot see volume functions in horizon ( but in horizon cinderv2 service is present and active ), second if i want to show volume-list by CLI i see

root@controller:~# nova --debug volume-list

WARNING: Command volume-list is deprecated and will be removed after Nova 13.0.0 is released. Use python-cinderclient or openstackclient instead.

DEBUG (shell:905) publicURL endpoint for volume service not found

......

EndpointNotFound: publicURL endpoint for volume service not found. ERROR (EndpointNotFound): publicURL endpoint for volume service not found

i guess this is an authentication problem i have used both v3 and v2.0 api policy but nothing changes.

Any idea were i have to point my attention to solve ?

Thanks

Raffaele

--- result of keystone endpoint-list is

WARNING: unsupported identity-api-version 3, falling back to 2.0
Authorization Failed: The resource could not be found. (HTTP 404) (Request-ID: req-cdf6eaeb-9fd0-4b6c-b6c9-a4dd7bdff18a)
edit retag flag offensive close merge delete

Comments

This is unreadable; please format your output as code.

Bernd Bausch gravatar imageBernd Bausch ( 2015-10-24 00:01:37 -0600 )edit

sorry i have changed description of my issue right now

lgctelecom gravatar imagelgctelecom ( 2015-10-24 04:19:09 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-25 00:37:29 -0600

Bipin gravatar image

Could you please show the output of

keystone endpoint-list

Regards

edit flag offensive delete link more

Comments

added result of keystone endpoint-list in my post thanks

lgctelecom gravatar imagelgctelecom ( 2015-10-25 01:27:27 -0600 )edit

It says, Authorization Failed. Are you sure, you have the correct username and Password ?

Bipin gravatar imageBipin ( 2015-10-26 04:05:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-10-21 12:16:19 -0600

Seen: 5,313 times

Last updated: Oct 25 '15