Ask Your Question
0

How to fix error 404 when devstack install on compute node tries to create alt_demo project on controller node.

asked 2015-10-20 19:06:11 -0500

GSCORREA gravatar image

During the devstack installation on a compute node there is step to create a project on the controller node. Failed command below

openstack --os-url=http://<controllerip>:5000/v3 --os-identity-api-version=3 project create alt_demo --domain=default --or-show -f value -c id

This steps fails with error 404.

2015-10-20 21:45:47.287 | The resource could not be found. (HTTP 404)

I entered the same command with debug option and got the following. P.S: I did change the controller IP address and password for security reasons.

openstack --os-url=http://<controllerip>:5000/v3 --os-identity-api-version=3 project create alt_demo --domain=default --or-show -f value -c id --debug START with options: ['--os-url=http://<controllerip>:5000/v3', '--os-identity-api-version=3', 'project', 'create', 'alt_demo', '--domain=default', '--or-show', '-f', 'value', '-c', 'id', '--debug'] options: Namespace(access_token_endpoint='', auth_type='v2password', auth_url='http://<controllerip>:35357', cacert='', client_id='', client_secret='', cloud='', debug=True, default_domain='default', deferred_help=False, domain_id='', domain_name='', endpoint='', identity_provider='', identity_provider_url='', insecure=None, interface='', log_file=None, os_compute_api_version='', os_identity_api_version='3', os_image_api_version='', os_network_api_version='', os_object_api_version='', os_project_id=None, os_project_name=None, os_volume_api_version='', password='<password>', project_domain_id='default', project_domain_name='', project_id='', project_name='admin', protocol='', region_name='', scope='', service_provider_endpoint='', timing=False, token='', trust_id='', url='http://<controllerip>:5000/v3', user_domain_id='default', user_domain_name='', user_id='', username='admin', verbose_level=3, verify=None) defaults: {'auth_type': 'password', 'compute_api_version': '2', 'key': None, 'database_api_version': '1.0', 'api_timeout': None, 'baremetal_api_version': '1', 'cacert': None, 'image_api_use_tasks': False, 'floating_ip_source': 'neutron', 'orchestration_api_version': '1', 'interface': None, 'network_api_version': '2', 'image_format': 'qcow2', 'object_api_version': '1', 'image_api_version': '2', 'verify': True, 'identity_api_version': '2.0', 'volume_api_version': '1', 'cert': None, 'secgroup_source': 'neutron', 'dns_api_version': '2', 'disable_vendor_agent': {}} cloud cfg: {'auth_type': 'v2password', 'compute_api_version': '2', 'orchestration_api_version': '1', 'database_api_version': '1.0', 'interface': None, 'network_api_version': '2', 'image_format': 'qcow2', 'object_api_version': '1', 'image_api_version': '2', 'verify': True, 'timing': False, 'dns_api_version': '2', 'project_domain_id': 'default', 'project_name': 'admin', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, 'baremetal_api_version': '1', 'auth': {'username': 'admin', 'tenant_name': 'admin', 'password': '<password>', 'auth_url': 'http://<controllerip>:35357'}, 'default_domain': 'default', 'image_api_use_tasks': False, 'floating_ip_source': 'neutron', 'key': None, 'cacert': None, 'user_domain_id': 'default', 'deferred_help': False, 'identity_api_version': '3', 'volume_api_version': '1', 'url': 'http://<controllerip>:5000/v3', 'cert': None, 'secgroup_source': 'neutron', 'debug': True, 'disable_vendor_agent': {}} compute API version 2, cmd group openstack.compute.v2 network API version 2, cmd group openstack.network.v2 image API version 2, cmd group openstack.image.v2 volume API version 1, cmd group openstack.volume.v1 identity API version 3, cmd group openstack.identity.v3 object_store API version 1, cmd group openstack.object_store.v1 command: project create -> openstackclient.identity.v3.project.CreateProject Auth plugin v2password selected auth_type: v2password Using auth plugin: v2password Using parameters {'username': 'admin', 'tenant_name': 'admin', 'password': '<password>', 'auth_url': 'http://<controllerip>:35357'} Get auth_ref Making authentication request to http://<controllerip>:35357/tokens Starting new HTTP connection (1): <controllerip> "POST /tokens HTTP/1.1" 404 93 Request returned failure status: 404 The resource could not be found. (HTTP 404) Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/cliff/app.py", line 367, in run_subcommand self.prepare_to_run_command(cmd) File "/usr/local/lib/python2.7/dist-packages/openstackclient/shell.py", line 344, in prepare_to_run_command self.client_manager.auth_ref File "/usr/local/lib/python2.7/dist-packages/openstackclient/common/clientmanager.py", line 189, in auth_ref self._auth_ref = self.auth.get_auth_ref ... (more)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-30 18:21:25 -0500

GSCORREA gravatar image

I found what was causing the error. When I did source the controller node admin file, the variable OS_AUTH_TYPE got set with value of v2password and somehow it was breaking the logic used to decide the type of auth to use to access the controller node.

Once I unset that variable the command worked.

I would like to know exactly what was getting broken by having this variable set.

edit flag offensive delete link more
0

answered 2015-11-16 13:10:29 -0500

msaif1982 gravatar image

I am stuck on a similar error but mine gets past this and get stuck up at project create alt_demo --domain=default,

It says below openstack project create: error: unrecognized arguments: --domain=default

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-20 17:59:41 -0500

Seen: 413 times

Last updated: Oct 30 '15