openstack kilo demo (401) in the cli - dashboard works

asked 2015-10-20 06:39:15 -0500

mickey gravatar image

updated 2015-10-20 07:04:12 -0500

Hi. I installed my whole 3 node Cluster from beginning.. I stuck at testing the demo user. Some hours earlier it worked without a problem. Now everytime i test something as demo user it tells me:

    cinder --debug create --name demo 1
DEBUG:keystoneclient.session:REQ: curl -g -i -X GET http://controller:5000/v3 -H "Accept: application/json" -H "User-Agent: python-keystoneclient"
DEBUG:keystoneclient.session:RESP: [200] content-length: 249 vary: X-Auth-Token keep-alive: timeout=5, max=100 server: Apache/2.4.7 (Ubuntu) connection: Keep-Alive date: Tue, 20 Oct 2015 11:31:40 GMT x-openstack-request-id: req-17fd19b8-5eb4-4949-8fe7-1484221d4b09 content-type: application/json x-distribution: Ubuntu 
RESP BODY: {"version": {"status": "stable", "updated": "2015-03-30T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v3+json"}], "id": "v3.4", "links": [{"href": "http://controller:5000/v3/", "rel": "self"}]}}

DEBUG:keystoneclient.auth.identity.v3:Making authentication request to http://controller:5000/v3/auth/tokens
DEBUG:keystoneclient.session:Request returned failure status: 401
ERROR: The request you have made requires authentication. (HTTP 401) (Request-ID: req-ebf59e19-5ab4-4dac-8fb9-d15c9a4c328e)
root@Controller ~ # openstack --os-auth-url http://controller:5000 \
>   --os-project-domain-id default --os-user-domain-id default \
>   --os-project-name demo --os-username demo --os-auth-type password \
>   token issue
ERROR: openstack The request you have made requires authentication. (HTTP 401) (Request-ID: req-5d77ffb5-c89d-40e8-813e-39f64ab4556b)

I already checked if the credentials are fine. i deleted the user over the cli and made the same again.

It all worked when i tested the Identity service.

The most strange thing is, that it all works when i use the Dashboard. I can do everything what the demo user is able to. But i am not allowed to execute commands in the CLI as demo client.

yes i sourced the demo-openrc.sh and i checked the credentials. When i use a command with password prompt, keystone doesn't let this happen.

Any idea?

edit retag flag offensive close merge delete