ERROR failed synchronizing routers ... rpc timeout [closed]

asked 2013-12-09 06:46:25 -0500

anonymous user

Anonymous

updated 2013-12-09 09:22:11 -0500

darragh-oreilly gravatar image

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log

2013-12-09 22:18:20.756 2510 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Traceback (most recent call last):
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 750, in _sync_routers_task
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     context, router_ids)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 75, in get_routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     topic=self.topic)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/proxy.py", line 130, in call
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     exc.info, real_topic, msg.get('method'))
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Timeout: Timeout while waiting on RPC response - topic: "q-l3-plugin", RPC method: "sync_routers" info: "<unknown>"
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 598.002945 sec
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 560.003462 sec

I am getting following output after running command "ip a"

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:56:56 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.18/16 brd 172.16.255.255 scope global eth0
    inet6 fe80::250:56ff:fe91:5656/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:6c:43 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.111/16 brd 172.16.255.255 scope global eth1
    inet6 fe80::250:56ff:fe91:6c43/64 scope link
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::250:56ff:fe91:32e5/64 scope link
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 5a:ef:48:02:d3:69 brd ff:ff:ff:ff:ff:ff
6: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.113/16 brd 172.16.255 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2017-05-24 13:55:18.913341

Comments

This is weird because obviously your neutron.conf is good enough so that agent-list works. It is something to do with RPC. Your eth0 and eth1 both have an address on the same subnet. Could an asymmetric route between the netnode and controller be confusing the complex rpc middleware?

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-12-09 09:36:29 -0500 )edit

I have the same problem but the eth0,eth1 addresses are not in same netmask!!

Agent out of sync with plugin!

Moe gravatar imageMoe ( 2014-12-07 03:18:04 -0500 )edit

Closing: Your question refers to a version of OpenStack which has been designated End Of Life. (See http://releases.openstack.org for details). If you're still having the problem with a more recent version, please open a new question with updated details. Thanks.

rbowen gravatar imagerbowen ( 2017-05-24 13:55:12 -0500 )edit