Ask Your Question
1

[openstack-dev] [Ceilometer] Ceilometer-Alarm-Not Working

asked 2015-10-15 23:04:44 -0500

mark gravatar image

Hi all,

I am working with Ceilometer-Kilo on RHEL 7.0. Initially, ceilometer configuration installed four ceilometer services:

Everything is installed and working perfectly.

I created alarm at a resource by using this command: ceilometer -k alarm-threshold-create --name testercpuhigh --description 'overheating?' --meter-name cpuutil --threshold 3.0 --comparison-operator gt --statistic avg --period 10 --query resourceid=e0bbdad3-ebdb-4acd-8fb5-cd2e10bb10f4

but whenever I check the status of alarm, it shows me 'insufficient data' status.

I tested it by running different applications on my instance but they made no change in alarm_status.

Please tell me which step is missing or what exact procedure should be followed in order to monitor a meter for a resource.

Thank you!

Regards, Mark lynn

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-10-16 02:05:36 -0500

Cheng Liu gravatar image

If your sampling interval is greater than period, it will lead to insufficient data.

Check the "interval" in /etc/ceilometer/pipeline.yaml.

- name: cpu_source
  interval: 5
  meters:
      - "cpu"
  sinks:
      - cpu_sink

The "interval" above should be less than or equal to "period" in your alarm.

edit flag offensive delete link more

Comments

Thank you for reply. My interval is 60. And I put the period to 600 then also same problem occurs. Please revert back for this issue.

mark gravatar imagemark ( 2015-10-16 03:25:01 -0500 )edit

Did ceilometer fetch any samples? Could you take a look at the sample list of the meter you want to monitor?

Cheng Liu gravatar imageCheng Liu ( 2015-10-16 04:22:54 -0500 )edit

Yes it is fetching samples from other components.

mark gravatar imagemark ( 2015-10-16 04:48:30 -0500 )edit

This is the sample of resource id | e2469be8-4b02-11e5-b7a2-0800271db522 | 060b5b1f-6dd8-4ec1-b95f-dd7c4328027b | cpu_util | gauge | 27.4666666667 | % | 2015-08-25T08:25:46 |

mark gravatar imagemark ( 2015-10-16 05:02:23 -0500 )edit

Thankyou for your all support, My work being done. :)

mark gravatar imagemark ( 2015-10-16 05:12:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-10-15 23:04:44 -0500

Seen: 416 times

Last updated: Oct 16 '15