Ask Your Question
0

openstack-nova-compute dosen't start??

asked 2015-10-15 13:00:05 -0600

majd.alshimali gravatar image

hi to all I'am installing openstack as mention in the instruction book when I try to start the compute service in compute node systemctl start openstack-nova-compute.service it 's just freeze
I check to conf file many time I am sure that every thing is OK this the Log file in the Compute Node

2015-10-13 19:48:20.429 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed
2015-10-13 19:48:24.450 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed
2015-10-13 19:48:28.471 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed
2015-10-13 19:48:32.490 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed
2015-10-13 19:48:36.508 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed
2015-10-13 19:48:40.526 1280 ERROR oslo_messaging._drivers.impl_rabbit [req-4391b5d6-dcbb-4aee-9823-e499041eec9c - - - - -] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed

and the rabbitMG Log in the controller

=ERROR REPORT==== 13-Oct-2015::19:48:57 ===
closing AMQP connection <0.3808.0> (10.10.10.10:40273 -> 10.10.10.10:5672):
{handshake_error,starting,0,
                 {amqp_error,access_refused,
                             "AMQPLAIN login refused: user 'openstack' - invalid credentials",
                             'connection.start_ok'}}

> should I Install rabbitmq-server in the compute node or just in the controller Thanks .. alot

edit retag flag offensive close merge delete

Comments

the credentials is true in the config file and the firewalld is off in the controller and compute node and iptables also off

majd.alshimali gravatar imagemajd.alshimali ( 2015-10-15 13:02:59 -0600 )edit

No , we do not install rabbit on compute. this seems to be a problem on rabbit. if possible try to re-install it. Also , if your cloud is private , try to use simple password or may be common password for all services. this will make life easier for you ( only in case of small private cloud )

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-15 22:56:03 -0600 )edit

The fact that you get an answer from the rabbitmq server indicates that your firewall is not the problem. Most likely you are wrong, and you don't use the correct passwd. As Ritesh says, for test installations, just use the same passwd (I use "pw") for everything.

Bernd Bausch gravatar imageBernd Bausch ( 2015-10-15 23:43:06 -0600 )edit

I delete the user and add it again with the same password for all the componets the same result nothing change (It just freez like it goes in infinit loop) how can i check the port that the compute used to connect the controller rabbit server ,,

majd.alshimali gravatar imagemajd.alshimali ( 2015-10-18 16:33:06 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-16 03:24:34 -0600

Vinoth gravatar image

1) Double check the user credentials of RabbitMQ mentioned in the conf file.

2) If possible, recreate/change the username and password of rabbitmq user. Then update the details in all rabbitMQ configurations in all OpenStack service conf file.

3) Check the appropriate ports of the controller that need to be open for rabbitmq to connect with the compute node.

edit flag offensive delete link more

Comments

I delete the user openstack and re-add user openstack with the password the same result , How can I check the ports in step 3 ?? and thanks for your answer

majd.alshimali gravatar imagemajd.alshimali ( 2015-10-18 16:30:20 -0600 )edit

The RabbitMQ userid. (string value)

    # Deprecated group;name - DEFAULT;rabbit_userid
    rabbit_userid = openstack

    # The RabbitMQ password. (string value)
    # Deprecated group;name - DEFAULT;rabbit_password
    rabbit_password = secret
majd.alshimali gravatar imagemajd.alshimali ( 2015-10-18 16:45:58 -0600 )edit

in the log

AMQP server controller:5672 closed the connection. Check login credentials: Socket closed

I am sure the the user & password is correct I remover and re-install rabbitmq , and the same problem , it just freez

majd.alshimali gravatar imagemajd.alshimali ( 2015-10-18 19:12:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-10-15 13:00:05 -0600

Seen: 1,590 times

Last updated: Oct 16 '15