Ask Your Question
0

Why is openstack still using api version v2 and not v3 for api endpoints?

asked 2015-10-15 07:37:28 -0500

soumitrakarmakar gravatar image

With the v3 service api available why is openstack still using v2 api for service endpoints in liberty?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-15 10:23:29 -0500

mpetason gravatar image

The most basic reason is that each service is a different project, which means that each service has it's own list of important features to add. If v3 API support isn't at the top of the list, then it won't make it in. Keystone v3 has been out for a while and most services are still not using it by default.

We may want a Dev to come in and write up a cleaner answer though.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-15 07:37:28 -0500

Seen: 79 times

Last updated: Oct 15 '15