Ask Your Question
0

gre missing on ovs-vsctl show

asked 2015-10-13 15:27:38 -0500

There are tons of questions and answers about instances not receiving DHCP, but after following the suggestions of most of them, I haven't found any solution to my problem yet.

I followed the documentation step by step, I get to launch instances which gets an IPs assigned on "nova list" but do not get configured automatically by dhcp. As a difference with the most of the other posts I found, I don't get any "gre" in ovs-vsctl show.

My set up:

CentOS 7 + Kilo
3x (KVM) VMs (controller, network, compute), 3 virtual networks (NAT)
10.0.0.0/24 management (eth0)
10.0.1.0/24 tunnel (eth1)
10.0.2.0/24 storage/external (eth2)

From network node:

ip netns
qdhcp-5eaa4c63-1d6b-4e37-914b-2d2660176e82
qrouter-d8d24185-9caf-4540-bb66-02a804df29d6

Ping gateway of the "demo-net":

ip netns exec qdhcp-5eaa4c63-1d6b-4e37-914b-2d2660176e82 ping -c1 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.915 ms

The dhcp server (192.168.1.2) also answers, and they both answer also from the qrouter namespace.

brtcl show outputs nothing

ip netns exec qdhcp-5eaa4c63-1d6b-4e37-914b-2d2660176e82 netstat -anp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 192.168.1.2:53          0.0.0.0:*               LISTEN      22287/dnsmasq      
tcp6       0      0 fe80::f816:3eff:feef:53 :::*                    LISTEN      22287/dnsmasq      
udp        0      0 192.168.1.2:53          0.0.0.0:*                           22287/dnsmasq      
udp        0      0 0.0.0.0:67              0.0.0.0:*                           22287/dnsmasq      
udp6       0      0 fe80::f816:3eff:feef:53 :::*                                22287/dnsmasq      
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node   PID/Program name     Path
unix  2      [ ]         DGRAM                    2892403  22287/dnsmasq 






ovs-vsctl show
4e05ffb1-b64a-4a05-8dc7-ba76291949d0
    Bridge br-ex
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
        Port "qr-14380065-57"
            tag: 1
            Interface "qr-14380065-57"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qg-cbbf7632-1b"
            tag: 4095
            Interface "qg-cbbf7632-1b"
                type: internal
        Port "tap1bd431d3-4a"
            tag: 1
            Interface "tap1bd431d3-4a"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
    Bridge br-tun
        fail_mode: secure
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.3.1"

I seem to be missing the "gre" in the tunnel, but how do I get it up?

My configuration is point by point the one in the RHEL Kilo documentation, so I guess there very few things I might have done wrong. I also don't get any error message on the logs.

Some additional outputs..

Network node:

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP ...
(more)
edit retag flag offensive close merge delete

Comments

Please share which doc you are referring and neutron config file.

prasad9920 gravatar imageprasad9920 ( 2015-10-14 01:29:11 -0500 )edit

CentOS 7 Kilo http://docs.openstack.org/kilo/instal... The config files are default ones only with the modifications from the documentation

Julen Larrucea gravatar imageJulen Larrucea ( 2015-10-14 04:18:54 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-03 04:08:14 -0500

updated 2015-11-04 03:35:57 -0500

I finally got the "gre" interface on the br-tun, thanks to the help of the Rackspace network gurus James Denton and Phil Hopkins at the Tokyo Summit. Thank you very much!

The "local_ip" variable on the "ovs" section on the /etc/neutron/plugins/ml2/ml2_conf.ini file of the compute node was wrong. Also forgot to add "NM_CONTROLLED=no" and "DEFROUTE=no" on my ifcfg-eth1 (tunnel) interface configuration (CentOS 7) on network and compute nodes.

So, the "gre" interface on the network node can not be created without a properly working openvswitch on the compute node.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-13 15:27:38 -0500

Seen: 501 times

Last updated: Nov 04 '15