Ask Your Question
1

ip netns does not show anything? [closed]

asked 2015-10-13 07:30:12 -0500

cloudlearner gravatar image

Configured icehouse with neutron three node setup (controller, network and compute) I have configured public and private network on dashboard for vm's. Moreover i have also attached router interface, gateway and assigned floating ip to vm, but still no namespaces are displayed.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by cloudlearner
close date 2015-10-26 23:57:44.532785

Comments

where are you looking for namespaces ? node ?

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-14 04:09:35 -0500 )edit

It's possible to run Neutron without namespaces. Check for the use_namespaces parameter in files like l3_agent.ini. Also, I am not certain if namespaces are created before an instance is run. Perhaps you need to launch an instance first.

Bernd Bausch gravatar imageBernd Bausch ( 2015-10-14 06:09:58 -0500 )edit

Agree with Bernd , namespaces donot get created when router or dhcp are created , its created when you attach a network to a VM ( for eg - during boot) or when a gateway is set for the VM network.

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-14 06:34:40 -0500 )edit

@Ritesh: I am looking for namespaces on network node

cloudlearner gravatar imagecloudlearner ( 2015-10-15 02:07:31 -0500 )edit

@Bernd : I have checked files like l3_agent.ini and dhcp_agent.ini. The parameter use_namespaces is set to true. Also I have checked namespaces after setting gateway, adding interface and launching instance. But still it shows nothing.

cloudlearner gravatar imagecloudlearner ( 2015-10-15 02:09:49 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-10-15 05:42:01 -0500

cloudlearner gravatar image

updated 2015-10-26 23:56:31 -0500

finally got the solution, this is my fault that i have ran multiple neutron services on each node that makes conflict.

edit flag offensive delete link more
0

answered 2015-10-14 03:17:15 -0500

updated 2015-10-15 07:24:03 -0500

I am not sure whether my setup is 100% right, but except for they typical "instance not seeing the dhcp" issue everything else works fine. I have this:

ip netns # at controller and compute return nothing

On the network node

ip netns
qdhcp-5eaa4c63-1d6b-4e37-914b-2d2660176e82
qrouter-d8d24185-9caf-4540-bb66-02a804df29d6

[root@network neutron]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:0f:2a:56 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.21/24 brd 10.0.0.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe0f:2a56/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:67:0c:73 brd ff:ff:ff:ff:ff:ff
    inet 10.0.1.21/24 brd 10.0.1.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe67:c73/64 scope link 
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000
    link/ether 52:54:00:af:31:2d brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:feaf:312d/64 scope link 
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether 06:ef:4c:38:df:5d brd ff:ff:ff:ff:ff:ff
6: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether 42:d3:32:31:82:42 brd ff:ff:ff:ff:ff:ff
7: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether 92:e0:74:a7:1e:42 brd ff:ff:ff:ff:ff:ff
10: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether 8e:ef:1f:29:c5:48 brd ff:ff:ff:ff:ff:ff

Do you mean that you don't get the qrouter and qdhcp namespaces on the network node?

Update: First of all, one obsevation: your eth2 does not have the PROMISC mode enabled (I'll show you my This is my network node configuration

CentOS 7 + 3 node KVM VMs 3 virtual networks 10.0.0.0, 10.0.1.0, 10.0.2.0 as in the documentation. IPs also as in the documentation (controller: 11, network:21 and compute:31)

setenforce 0 && systemctl stop firewalld

cat  > /etc/sysconfig/network-scripts/ifcfg-eth2 << EOF
DEVICE=eth2
TYPE=Ethernet
ONBOOT="yes"
BOOTPROTO="none"
PROMISC=yes
EOF
  ifdown eth2 && ifup eth2
  ifconfig eth2 promisc
  echo "ifconfig $IFACE1 promisc" >> /etc/rc.local


  echo "net.ipv4.ip_forward=1" |tee -a  /etc/sysctl.conf
  echo "net.ipv4.conf.all.rp_filter=0" |tee -a  /etc/sysctl ...
(more)
edit flag offensive delete link more

Comments

Yes. Also I am not getting IP in instances through dhcp though it is being showed on dashboard.

cloudlearner gravatar imagecloudlearner ( 2015-10-15 02:13:53 -0500 )edit

Which operative system are you using? Are you sure all the services are running? Try: for S in neutron-openvswitch-agent neutron-l3-agent neutron-dhcp-agent neutron-metadata-agent; do service $S status |grep -e Loaded -e running; done

What does "ip a" show? Do you see the new interfaces?

Julen Larrucea gravatar imageJulen Larrucea ( 2015-10-15 02:58:26 -0500 )edit

Julen..I need to use the answer field to give the response. Please look into the answer .

cloudlearner gravatar imagecloudlearner ( 2015-10-15 05:37:52 -0500 )edit

I updated my answer. I am having a similar issue, and it seems that we might be able to help each other to complement each others missing parts. My br-ex interface does not have any IP assigned, and I don't have the phys-br-ex.

Julen Larrucea gravatar imageJulen Larrucea ( 2015-10-15 07:33:12 -0500 )edit

on network node you need to add the br-ex with your eth port through which internet is accessible. BY

ovs-vsctl add br-ex eth

you can follow this for configuration [link text](http://ask.openstack.org/en/question/79821/no-internet-connectivity-on-instances-with-each-other-and-external-network/

cloudlearner gravatar imagecloudlearner ( 2015-10-16 05:03:33 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-13 07:30:12 -0500

Seen: 3,382 times

Last updated: Oct 26 '15