usefullness of packstack with other bits already installed

asked 2015-10-09 09:00:25 -0500

hi everybody,

I wonder if 'packstack --allinone' fails on my system because components like mariadb are already installed & configured? First it failed with:

Blockquote

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install mariadb' returned 1: Removing mariadb.x86_64 1:5.5.44-1.el7_1 - u due to obsoletes from installed MariaDB-client-10.0.21-1.el7.centos.x86_64

Blockquote

Ok, so I tried with: --mariadb-install=n --mariadb-pw=xxxxxx got this:

Blockquote

ERROR : Error appeared during Puppet run: 192.168.2.110_mariadb.pp Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class ::remote::db at /var/tmp/packstack/91c26d05d3be4b43be1c3a4c287edb65/manifests/192.168.2.110_mariadb.pp:11 on node

Blockquote

I wonder whether there is a tutorial/doc where using - packstack - would be explain in terms of braking it down to separate components/dependencies? On a system that is already fully functional (for most tasks)? And what does this error say?

best wishes.

edit retag flag offensive close merge delete