Ask Your Question
0

ip addr -4 error in l3-agent.log blocking floating ip

asked 2015-10-06 16:40:49 -0500

hansenb gravatar image

Kilo on ubuntu 14.04

While debugging issues with pinging floating ip and instance ips, I found this error in the l3-agent.log. This is probably one of many issues I'm having getting my floating-ip's pingable. This is the only error I can find in the log files.

2015-10-06 09:19:53.801 26422 ERROR neutron.agent.linux.utils [-]
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ip', 'netns', 'exec', 'qrouter-94901210-376b-41f6-a07a-2fadb2f50c82', 'ip', '-4', 'addr', 'add', '10.20.82.151/32', 'scope', 'global', 'dev', 'qg-f72a9503-b9', 'brd', 'None']
Exit code: 1
Stdin:
Stdout:
Stderr: Error: an inet address is expected rather than "None".

2015-10-06 09:19:53.802 26422 WARNING neutron.agent.l3.router_info [-] Unable to configure IP address for floating IP: c22b8547-b885-4c2e-ba18-db9097b7037c

Reading this it appears the broadcast address is null. Where should that be set?

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-06 17:00:13 -0500

hansenb gravatar image

updated 2015-10-06 17:00:50 -0500

I fixe this error message at least. This bug describes the issue:

https://review.openstack.org/#/c/218852/

I reverted my system to netaddr 0.7.15 and the error went away when creating new floating ips. I had 0.7.18 installed.

What I don't know is why I didn't get the fix, as I built this system last week using the various apt-get commands.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-06 16:40:49 -0500

Seen: 217 times

Last updated: Oct 06 '15