Ask Your Question
0

Not able to view the interface of Horizon

asked 2013-12-07 07:59:09 -0500

anonymous user

Anonymous

updated 2014-01-22 15:12:41 -0500

Evgeny gravatar image

Hi,

I am running Openstack after one month, the problem I have got is

  1. I stacked devstack with ./stack.sh
  2. I got my horizon and keystone running successfully and got the url that runs horizon
  3. When I copy that url into the client (mozilla) I am not getting Horizon dashboard displayed.
  4. Instead I am getting an error : Unable to connect "Firefox can't establish a connection to the server at csvm2c4d.kent.ac.uk.The site could be temporarily unavailable or too busy. Try again in a few moments"

  5. But I am able to ping the ip address and it works.

Please help

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-03 09:37:48 -0500

Nitesh gravatar image

i am not able to login also ,it is displaying err_connection_timed out(webpage is not available) .

edit flag offensive delete link more
0

answered 2016-08-09 01:57:26 -0500

DebD gravatar image

In my case, port 80 use blocked on Host. Let me elaborate my use case: [Problem]

  • Installed devstack on HOST
  • All services was up and running. No error on Horizon. Apache was configured and nothing suspicious (as described above)
  • I can ping newly created VM from devstack (As I added port 22 to costume rules in "Access and Security")
  • Forgot to add port 80 in "Access and Security" rules
  • Not able to access horizon
  • Added port 80 to ccess and Security" rules
  • Now able to access horizon from my browser.
edit flag offensive delete link more
0

answered 2013-12-14 14:46:36 -0500

jtopjian gravatar image

Hello,

On your devstack server, verify that something is listening on port 80 by doing:

$ sudo netstat -nap | grep 80

If so, then a firewall is probably blocking connections to port 80.

Hope that helps -Joe

edit flag offensive delete link more

Comments

tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN 11689/apache2 tcp 0 0 0.0.0.0:6080 0.0.0.0:* LISTEN 23027/python tcp 1 0 129.12.44.77:53439 91.189.94.25:80 CLOSE_WAIT 2153/ubuntu-geoip-p udp 0 0 0.0.0.0:58095 0.0.0.0:* 652/avahi-daemon: r This is what I am getting, from above I can see that 129.12.44.77 is not running on port 80, that is what I need to run in port 80 to get my interface up. Any idea on the steps to be performed ? Thank you

Deepak gravatar imageDeepak ( 2013-12-15 12:55:09 -0500 )edit

It looks like apache is running on port 8080 -- probably Swift. Devstack should have created a screen terminal dedicated to Horizon. Are there any errors there? Are there any errors under /var/log/apache2?

jtopjian gravatar imagejtopjian ( 2013-12-15 13:11:25 -0500 )edit

Yes, I have got the horizon_error.log and few other horizon related error files to be empty. And the actual error.log holds the following warning errors [Sun Dec 15 08:03:40 2013] [warn] mod_wsgi: Compiled for Python/2.7.2+. [Sun Dec 15 08:03:40 2013] [warn] mod_wsgi: Runtime using Python/2.7.3. [Sun Dec 15 08:03:40 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.8 with Suhosin-Patch mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations Thank you

Deepak gravatar imageDeepak ( 2013-12-15 13:34:54 -0500 )edit

Can you confirm that /etc/apache2/sites-enabled/ has a valid Horizon configuration? Can you restart the Apache service to see if it begins listening on port 80?

jtopjian gravatar imagejtopjian ( 2013-12-15 13:38:02 -0500 )edit

And devstack successfully created the terminal for Horizon which gives me the usual message that Horizon is now running at http://129.12.44.77/ which is my local host

Deepak gravatar imageDeepak ( 2013-12-15 13:38:27 -0500 )edit
0

answered 2013-12-15 13:52:27 -0500

Deepak gravatar image

Hi,

The following error should help, is that warning of mod_wsgi using different versions of python during compile time and run time an issue ? Please have a look at the following error log of apache and advise

[Sun Dec 08 07:37:15 2013] [warn] mod_wsgi: Compiled for Python/2.7.2+. [Sun Dec 08 07:37:15 2013] [warn] mod_wsgi: Runtime using Python/2.7.3. [Sun Dec 08 07:37:15 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.8 with Suhosin-Patch mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations [Wed Dec 11 17:49:22 2013] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico [Wed Dec 11 17:49:22 2013] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico [Wed Dec 11 17:49:40 2013] [error] [client 129.12.44.77] File does not exist: /var/www/favicon.ico [Wed Dec 11 17:52:51 2013] [error] [client 129.12.44.77] File does not exist: /var/www/favicon.ico [Wed Dec 11 17:52:51 2013] [error] [client 129.12.44.77] File does not exist: /var/www/favicon.ico [Wed Dec 11 17:58:26 2013] [error] [client 129.12.250.114] File does not exist: /var/www/favicon.ico [Wed Dec 11 20:19:58 2013] [notice] caught SIGTERM, shutting down [Wed Dec 11 20:22:08 2013] [warn] mod_wsgi: Compiled for Python/2.7.2+. [Wed Dec 11 20:22:08 2013] [warn] mod_wsgi: Runtime using Python/2.7.3. [Wed Dec 11 20:22:08 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.8 with Suhosin-Patch mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations [Wed Dec 11 20:32:30 2013] [notice] caught SIGTERM, shutting down [Wed Dec 11 20:32:33 2013] [warn] mod_wsgi: Compiled for Python/2.7.2+. [Wed Dec 11 20:32:33 2013] [warn] mod_wsgi: Runtime using Python/2.7.3. [Wed Dec 11 20:32:33 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.8 with Suhosin-Patch mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations [Sun Dec 15 08:03:39 2013] [notice] Graceful restart requested, doing restart apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Thank you

edit flag offensive delete link more

Comments

Warnings usually don't cause hard failures. Since Apache is running on port 8080, it has not run into a hard error that would cause it to not run -- Apache will refuse to start if any site has an error.

jtopjian gravatar imagejtopjian ( 2013-12-15 21:16:08 -0500 )edit

How do i resolve this ? I just want apache to run the horizon ip in port 80, but I tried different ways still I am not getting it. I am getting the django server up running if I do python manage.py run server within my horizon folder. This gives me the horizon dashboard but that is not the modified dashboard in which I was working. Is there any way to remove all other ip and have just horizon running ?

Deepak gravatar imageDeepak ( 2013-12-16 14:54:55 -0500 )edit

What do you mean by "not the modified dashboard"? Did you make changes to the default devstack configuration?

jtopjian gravatar imagejtopjian ( 2013-12-16 15:03:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-07 07:59:09 -0500

Seen: 7,045 times

Last updated: Aug 09 '16