how to enable metadata in devstack kilo

asked 2015-10-04 11:08:37 -0500

ashok gravatar image

updated 2015-10-04 11:10:38 -0500

After installing stable devstack kilo from github , git clone https://git.openstack.org/openstack-dev/devstack (https://git.openstack.org/openstack-d...)

By default metadata_proxy_shared_secret is not enabled in /etc/neutron/metadata_agent.ini and nova.conf file. After uncommenting the line in these files(nova.conf and meta_agent.ini) meta-data service is failed to connect with 'Connection to 169.254.169.254 timed out". because of this unable to do ssh from external network.

so can anyone explain how to enable automatically and what are changes to be added in local.conf or stackrc file in devstack kilo.

edit retag flag offensive close merge delete