Ask Your Question
0

Some issues with Cinder and Horizon after the update [closed]

asked 2013-12-06 19:42:35 -0500

spcla1 gravatar image

updated 2013-12-06 19:46:33 -0500

In particular, the one that I haven't resolved yet is the cinder block storage on Horizon. The system doesn't see the volume storage from the dashboard, when login as admin the "System info" doesn't show the host and when I click the Volumes option the system crashed. WhenI clicked the Volume option as user, there no create volume option. I can create volume using CLI, though with problem. All other options from the dashboard works fine.

The cinder package installed were the following: python-cinder-2013.2-2.el6.noarch openstack-cinder-2013.2-2.el6.noarch python-cinderclient-1.0.7-1.el6.noarch

I tried to remove them so I can install the previous versions. was able to remove both: python-cinder-2013.2-2.el6.noarch openstack-cinder-2013.2-2.el6.noarch

and install openstack-cinder-2013.2-1.el6.noarch.rpm python-cinder-2013.2-1.el6.noarch.rpm

but not able to remove python-cinderclient-1.0.7-1.el6.noarch since it has a lot of dependencies, afraid that it might break more stuff.

Does this mean that python-cinderclient-1.0.7-1.el6.noarch is causing some issue with Horizon?

Any help would be great appreciated.

Forgot to mention: I am running Redhat and Havana

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by spcla1
close date 2014-03-06 19:15:32.615465

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-12-09 11:28:12 -0500

dradez gravatar image

updated 2013-12-09 11:28:30 -0500

Two questions

  1. could you provide some details on the update you did? There may be some configs that needed updating that could be causing this.

  2. What do you mean "I can create volume using CLI, though with problem" If you can't create a volume without issues on the command line then you won't be able to do it from the web interface either.

I would recommend looking at the logs in /var/log/cinder/

when you create a volume from the command line check those logs and see if you get errors.

If you could give a few more specifics we can try and figure out where the issue may be coming from.

edit flag offensive delete link more

Comments

Thanks for your response on my issue. Just solved my problem. It was related to the keystone endpoint, mistyped RegionOne to Regionone. Removed the cinder endpoint and added it back with the right region name and it worked. Thanks again.

spcla1 gravatar imagespcla1 ( 2013-12-11 20:33:22 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-06 19:42:35 -0500

Seen: 274 times

Last updated: Dec 09 '13