Ask Your Question
0

PasswordAuthentication change does not get reflected in a snapshot

asked 2015-10-03 15:33:14 -0500

Vimal gravatar image

Hello, I have downloaded a fedora22 cloud image for openstack. I changed the PasswordAuthentication from no to yes in /etc/ssh/sshd_configuration and created a snapshot. When I boot a VM from the saved snapshot, the PasswordAuthetication gets reverted to yes. Can you please tell me what I am doing wrong. My environment is as follows: Openstack version : Juno OpenSSH version : OpenSSH_6.8p1

Please help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-09 10:20:31 -0500

rozie gravatar image

Don't have Fedora 22 available, but on Fedora 21 is the same.

grep PasswordAuthentication /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication yes

Changed to: grep PasswordAuthentication /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication no

Then created snaphot and fresh instance from the snapshot and instance from shapshot and: grep PasswordA /etc/ssh/sshd_config

PasswordAuthentication yes

PasswordAuthentication yes

I believe cloud-init included in cloud Fedora images overwrites this setting. You can: 1. use puppet/chef/ansible to manage configuration 2. try setting chattr +i on that file before snapshot (but it can cause problems with cloud-init)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-10-03 15:33:14 -0500

Seen: 352 times

Last updated: Oct 09 '15