neutron agent-list command gives empy response

asked 2015-10-01 18:23:53 -0600

pl33g0r gravatar image

updated 2015-10-01 18:24:24 -0600

Hi,

I setting up openstack kilo on centos7 and I am running into problems verifying successful installation of neuton node. When I am running neutron agent-list on the controller nothing comes up.

These are my configs:

network node:

[DEFAULT]
 rpc_backend = rabbit
 core_plugin = ml2
 service_plugins = router
 allow_overlapping_ips = True
 verbose = True

[oslo_messaging_rabbit]
rabbit_host = 10.17.0.212
rabbit_userid = openstack
rabbit_password = password
auth_strategy = keystone

[keystone_authtoken]
auth_uri = http://10.17.0.212:5000
auth_url = http://10.17.0.212:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = neutron
password = password

ml2_conf.ini

enter code here
[ml2]
type_drivers = flat
tenant_network_types = flat
mechanism_drivers = openvswitch

[ml2_type_flat]
flat_networks = external

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]
local_ip = 10.0.1.11
bridge_mappings = external:br-ex

[agent]
tunnel_types = flat

Any reasons why this behavior exists? How should I troubleshoot this issue?

I can provide additional config info

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-02 12:11:06 -0600

pl33g0r gravatar image

after restating all neutron related services things went back to normal

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-01 18:23:53 -0600

Seen: 97 times

Last updated: Oct 02 '15