Ask Your Question
0

Unable to install keystone packageI

asked 2015-10-01 12:13:00 -0500

mehul_342001 gravatar image

updated 2015-10-02 11:57:21 -0500

smaffulli gravatar image

I have installed rhel 7.1 on the controller node.

When I tried to install keystone packages , It gives below error

yum install openstack-keystone httpd mod_wsgi python-openstackclient memcached python-memcached

--> Finished Dependency Resolution
Error: Package: python-pycadf-0.8.0-1.el7.noarch (openstack-kilo)
           Requires: python-webob >= 1.2.3
Error: Package: 1:python-keystoneclient-1.3.0-1.el7.noarch (openstack-kilo)
           Requires: python-webob
Error: Package: python-repoze-who-2.1-1.el7.noarch (openstack-kilo)
           Requires: python-zope-interface
Error: Package: python-keystonemiddleware-1.5.1-1.el7.noarch (openstack-kilo)
           Requires: python-webob
Error: Package: python-keystone-2015.1.1-1.el7.noarch (openstack-kilo)
           Requires: python-webob >= 1.2.3
Error: Package: python-repoze-who-2.1-1.el7.noarch (openstack-kilo)
           Requires: python-webob
Error: Package: python-pysaml2-3.0.0-1.el7.noarch (openstack-kilo)
           Requires: python-zope-interface
Error: Package: python-oslo-middleware-1.0.0-2.el7.noarch (openstack-kilo)
           Requires: python-webob
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I also tried to run yum install command using --skip-broken but it did not help

I research on this and found the that add exclude=python* in base redhat and rhel repo so that it will install new version of python.

I have downloaded the package from internet and now the error got reduced

--> Finished Dependency Resolution Error: Package: python-pysaml2-3.0.0-1.el7.noarch (openstack-kilo) Requires: python-zope-interface Error: Package: python-repoze-who-2.1-1.el7.noarch (epel) Requires: python-zope-interface You could try using --skip-broken to work around the problem ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows: python-webob-1.2.3-8.el6.noarch has missing requires of python(abi) = ('0', '2.6', None)

[root@controller ~]# yum list python-webob Loaded plugins: langpacks, product-id, subscription-manager This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. Installed Packages python-webob.noarch 1.2.3-8.el6 installed [root@controller ~]#
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-10-02 11:36:56 -0500

mehul_342001 gravatar image

I have observed that the package python-zope-interface-4.0.5-4.el7.x86_64.rpm was missing . I downloaded from the link http://www.rpmfind.net/linux/rpm2html/search.php?query=python-zope-interface&submit=Search+...&system=centos&arch= (http://www.rpmfind.net/linux/rpm2html...) , and installed, the issue got resolved

edit flag offensive delete link more
0

answered 2015-10-22 02:37:27 -0500

suresh gravatar image

I have also downloaded package from above link and problem got resolved .. thanks

edit flag offensive delete link more
0

answered 2015-10-01 17:32:38 -0500

updated 2015-10-02 11:58:50 -0500

smaffulli gravatar image

When you run "yum list python-webob", does it show as "Available Packages"? I suspect yum cannot find a valid repo that contains the required "python-webob" package.

If your controller does not have a valid yum repo, it will end up in a package dependency hell. If for some reason you cannot register Red Hat, I would recommend you use Fedora or Centos.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-10-01 12:13:00 -0500

Seen: 754 times

Last updated: Oct 02 '15