Kilo: Installing nova-compute package on ARM64 board having Ubuntu

asked 2015-09-30 23:15:21 -0600

Mahendra gravatar image

updated 2015-09-30 23:18:27 -0600

Hello,

I'm trying to add an ARM64 based board as a compute node to a working Kilo OpenStack installation with 3 x86 nodes. I've Ubuntu 14.04.1 LTS on the ARM64 board. I'm not able to install nova-compute package on the ARM64 board.

The error log is

E: Can not write log (Is /dev/pts mounted?) - openpty (2: No such file or directory)
Setting up libpam-systemd:arm64 (204-5ubuntu20.14) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: unknown initscript, /etc/init.d/systemd-logind not found.
dpkg: error processing package libpam-systemd:arm64 (--configure):
 subprocess installed post-installation script returned error exit status 100
Setting up cgroup-lite (1.9) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: unknown initscript, /etc/init.d/cgroup-lite not found.
dpkg: error processing package cgroup-lite (--configure):
 subprocess installed post-installation script returned error exit status 100
dpkg: dependency problems prevent configuration of cgroup-bin:
 cgroup-bin depends on cgroup-lite (>= 1.3); however:
  Package cgroup-lite is not configured yet.

dpkg: error processing package cgroup-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libvirt-bin:
 libvirt-bin depends on cgroup-lite | cgroup-bin; however:
  Package cgroup-lite is not configured yet.
  Package cgroup-bin is not configured yet.

dpkg: error processing package libvirt-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-compute-libvirt:
 nova-compute-libvirt depends on libvirt-bin; however:
  Package libvirt-bin is not configured yet.

dpkg: error processing package nova-compute-libvirt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-compute-kvm:
 nova-compute-kvm depends on nova-compute-libvirt (= 1:2014.1.5-0ubuntu1.3); however:
  Package nova-compute-libvirt is not configured yet.

dpkg: error processing package nova-compute-kvm (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-compute:
 nova-compute depends on nova-compute-kvm | nova-compute-hypervisor; however:
  Package nova-compute-kvm is not configured yet.
  Package nova-compute-hypervisor is not installed.
  Package nova-compute-kvm which provides nova-compute-hypervisor is not configured yet.

dpkg: error processing package nova-compute (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libpam-systemd:arm64
 cgroup-lite
 cgroup-bin
 libvirt-bin
 nova-compute-libvirt
 nova-compute-kvm
 nova-compute
E: Sub-process /usr/bin/dpkg returned an error code (1)

Has anyone tried to install nova-compute package on an ARM64 board (e.g. Juno board from ARM company) having Ubuntu 14.04.3 LTS ? What is the cause and solution for above errors ?

Thank you.

Mahendra

edit retag flag offensive close merge delete