Ask Your Question
0

Unable to start openstack-swift-proxy.service with kilo on Centos7

asked 2015-09-24 16:47:45 -0500

Rajan433 gravatar image

updated 2015-09-25 12:00:53 -0500

// Checking Status

[root@controller swift]# systemctl status openstack-swift-proxy.service

openstack-swift-proxy.service - OpenStack Object Storage (swift) - Proxy Server Loaded: loaded (/usr/lib/systemd/system/openstack-swift-proxy.service; enabled) Active: failed (Result: exit-code) since Wed 2015-09-23 19:45:37 EDT; 21h ago Process: 20147 ExecStart=/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf (code=exited, status=1/FAILURE) Main PID: 20147 (code=exited, status=1/FAILURE)

Sep 23 19:45:37 controller swift-proxy-server[20147]: global_conf=global_conf) Sep 23 19:45:37 controller swift-proxy-server[20147]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 328, in _loadegg Sep 23 19:45:37 controller swift-proxy-server[20147]: return loader.get_context(object_type, name, global_conf) Sep 23 19:45:37 controller swift-proxy-server[20147]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 620, in get_context Sep 23 19:45:37 controller swift-proxy-server[20147]: object_type, name=name) Sep 23 19:45:37 controller swift-proxy-server[20147]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 659, in find_egg_entry_point Sep 23 19:45:37 controller swift-proxy-server[20147]: for prot in protocol_options] or '(no entry points)')))) Sep 23 19:45:37 controller swift-proxy-server[20147]: LookupError: Entry point 'memcache\nmemcache_servers = 127.0.0.1:11211' not found in egg 'swift' (dir:...points: ) Sep 23 19:45:37 controller systemd[1]: openstack-swift-proxy.service: main process exited, code=exited, status=1/FAILURE Sep 23 19:45:37 controller systemd[1]: Unit openstack-swift-proxy.service entered failed state. Hint: Some lines were ellipsized, use -l to show in full.

// Starting the service. Does not show any error while command is run

[root@controller swift]# systemctl start openstack-swift-proxy.service

// Check the status again, but it failed as below

[root@controller swift]# systemctl status openstack-swift-proxy.service -l openstack-swift-proxy.service - OpenStack Object Storage (swift) - Proxy Server Loaded: loaded (/usr/lib/systemd/system/openstack-swift-proxy.service; enabled) Active: failed (Result: exit-code) since Thu 2015-09-24 17:38:59 EDT; 6s ago Process: 4766 ExecStart=/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf (code=exited, status=1/FAILURE) Main PID: 4766 (code=exited, status=1/FAILURE)

Sep 24 17:38:59 controller swift-proxy-server[4766]: global_conf=global_conf) Sep 24 17:38:59 controller swift-proxy-server[4766]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 328, in _loadegg Sep 24 17:38:59 controller swift-proxy-server[4766]: return loader.get_context(object_type, name, global_conf) Sep 24 17:38:59 controller swift-proxy-server[4766]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 620, in get_context Sep 24 17:38:59 controller swift-proxy-server[4766]: object_type, name=name) Sep 24 17:38:59 controller swift-proxy-server[4766]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 659, in find_egg_entry_point Sep 24 17:38:59 controller swift-proxy-server[4766]: for prot in protocol_options] or '(no entry points)')))) Sep 24 17:38:59 controller swift-proxy-server[4766]: LookupError: Entry point 'memcache\nmemcache_servers = 127.0.0.1:11211' not found in egg 'swift' (dir: /usr/lib/python2.7/site-packages; protocols: paste.filter_factory, paste.filter_app_factory; entry_points: ) Sep 24 17:38:59 controller systemd[1]: openstack-swift-proxy.service: main process ... (more)

edit retag flag offensive close merge delete

Comments

Any comments please? Appreciate the help!!

Rajan433 gravatar imageRajan433 ( 2015-09-28 07:59:23 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-24 18:25:27 -0500

Gerardo-Alfredo gravatar image

Could you please post your swift-proxy.conf file?

It looks like you don't have the line

memcache_servers = 127.0.0.1:11211

Set in the swift-proxy.conf file.

Hope you can fix the issue

Regards Gerardo.

edit flag offensive delete link more

Comments

Hi Gerardo,

Do you mean proxy-server.conf? I dont have swift-proxy.conf file? I am following kilo user guide. if you are referring to proxy-server.conf, it has in section below:

[filter:cache] use = egg:swift#memcache memcache_servers = 127.0.0.1:11211

I have added proxy-server.conf file above.

Rajan433 gravatar imageRajan433 ( 2015-09-25 11:57:34 -0500 )edit

Hi Gerardo,

Do you think you could provide some suggestions? Sorry to bother you. I am not getting any reply here.

Rajan433 gravatar imageRajan433 ( 2015-09-28 13:51:56 -0500 )edit

Well i have to apologize, i have been reading your proxy-server.conf. I had this issue once, it was because i had a typo on the file configurations, but i don't see any of it.

Does your server has correct urls to the endpoint? Is selinux in permisive mode?

Gerardo-Alfredo gravatar imageGerardo-Alfredo ( 2015-09-28 14:13:35 -0500 )edit

Appreciate your response. I have selinux disabled:

[root@controller ~]# sestatus SELinux status: disabled

I have endpoint for service swift, nova, keystone, glance, cinderv2, cinder all in RegionOne. As far as I know i followed user guide kilo configuring endpoint as instructed

Rajan433 gravatar imageRajan433 ( 2015-09-28 16:33:23 -0500 )edit
0

answered 2017-02-23 01:58:31 -0500

delete all key = value in [filter:tempauth] and delete [filter:tempauth]

[filter:tempauth]

use = egg:swift#tempauth

...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-09-24 16:47:45 -0500

Seen: 1,416 times

Last updated: Sep 25 '15