Ask Your Question
1

Instances can't ping servers by their domain name

asked 2015-09-22 12:51:10 -0600

weeix gravatar image

I followed OpenStack Installation Guide for Ubuntu 14.04(http://docs.openstack.org/kilo/install-guide/install/apt/content/ (http://docs.openstack.org/kilo/instal...)) step-by-step from chapter 1 to 6 (using neutron with 3 nodes).

However, after I launched an instance (chapter 12), I'm unable to ping http://openstack.org from that instance like the example in the 'To access your instance using a virtual console' section (http://docs.openstack.org/kilo/install-guide/install/apt/content/launch-instance-neutron.html#d6e4570 (http://docs.openstack.org/kilo/instal...)):

Verify the ext-net external network:

$ ping -c 4 openstack.org
PING openstack.org (174.143.194.225) 56(84) bytes of data.
64 bytes from 174.143.194.225: icmp_req=1 ttl=53 time=17.4 ms
64 bytes from 174.143.194.225: icmp_req=2 ttl=53 time=17.5 ms
64 bytes from 174.143.194.225: icmp_req=3 ttl=53 time=17.7 ms
64 bytes from 174.143.194.225: icmp_req=4 ttl=53 time=17.5 ms

--- openstack.org ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 17.431/17.575/17.734/0.143 ms

Here is my result:

$ ping -c 4 openstack.org
ping: bad address 'openstack.org'

And I'm quite sure that I didn't miss a thing about configuring dns servers. Every hosts can ping http://openstack.org normally.

edit retag flag offensive close merge delete

Comments

I think there is no DNS set in your /etc/resolv.conf for that instance.

herrsergio gravatar imageherrsergio ( 2015-09-22 13:50:15 -0600 )edit

@herrsergionameserver 192.168.1.2 lies within the instance's /etc/resolv.conf (instance's IP = 192.168.1.3, instance's gateway = 192.168.1.1)

weeix gravatar imageweeix ( 2015-09-22 21:10:16 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-09-23 07:03:03 -0600

updated 2015-09-25 04:22:22 -0600

Have a look on your neutron networking node at :

the /etc/neutron/dhcp_agent.ini file, section DEFAULT, entry dnsmasq_dns_servers

you should add the DNS for your network here

EDIT:

I have the following in my OpenStack installation script:

openstack-config --set /etc/neutron/dhcp_agent.ini DEFAULT dnsmasq_dns_servers $(awk '/^nameserver/ {print $2}' /etc/resolv.conf)

It takes the actual DNS server (which may have come through DHCP) and put that in the neutron dnsmasq configuration...

re-EDIT:

Always try ping 8.8.8.8 to be sure it is really a name service problem and not a network connectivity problem.

edit flag offensive delete link more

Comments

I changed the vaule to dnsmasq_dns_servers = 8.8.8.8, 8.8.4.4, then did a # service neutron-dhcp-agent restart. It works - I can ping openstack.org now. Thank you very much!

weeix gravatar imageweeix ( 2015-09-23 21:18:50 -0600 )edit

I am having same issue in new instance. Can ping 8.8.8.8 but not http://google.com or any other domain names. When I run service neutron-dhcp-agent restart, I get error - "Failed to restart neutron-dhcp-agent.service: Unit neutron-dhcp-agent.service not found." Any inputs as to what I may be missing

maruti gravatar imagemaruti ( 2017-01-20 06:37:04 -0600 )edit

BTW, I am running devstack on Ubuntu 16.04 server. When I run neutron agent-list command, DHCP agent is listed and I can see its alive field to be smiley ( :-) ) which I believe means that this agent is alive but don't know why I get neutron-dhcp-agent.service not found!

maruti gravatar imagemaruti ( 2017-01-20 06:56:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-09-22 12:51:10 -0600

Seen: 971 times

Last updated: Sep 25 '15