Ask Your Question
0

TRACE neutron ValueError: Empty module name

asked 2015-09-18 07:18:08 -0500

anonymous user

Anonymous

Hi everyone,

I am getting the following errors in my /var/log/neutron/server.log. I am getting these error populated when i running the following commands

systemctl enable neutron-server.service
systemctl start neutron-server.service

2015-09-18 17:32:47.156 649 TRACE neutron     cls._instance = cls()
2015-09-18 17:32:47.156 649 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/manager.py", line 114, in __init__
2015-09-18 17:32:47.156 649 TRACE neutron     plugin_provider)
2015-09-18 17:32:47.156 649 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/manager.py", line 135, in _get_plugin_instance
2015-09-18 17:32:47.156 649 TRACE neutron     plugin_class = importutils.import_class(plugin_provider)
2015-09-18 17:32:47.156 649 TRACE neutron   File "/usr/lib/python2.7/site-packages/neutron/openstack/common/importutils.py", line 27, in import_class
2015-09-18 17:32:47.156 649 TRACE neutron     __import__(mod_str)
2015-09-18 17:32:47.156 649 TRACE neutron ValueError: Empty module name

I tried to check all steps and it looks good. I followed the following link:http://docs.openstack.org/juno/install-guide/install/yum/content/neutron-controller-node.html.

Output of files - /etc/nova/nova.conf

[database]
connection = mysql://nova:redhat@controller/nova
[DEFAULT]
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = redhat
auth_strategy = keystone
my_ip = 192.168.1.2 
vncserver_listen = 192.168.1.2
vncserver_proxyclient_address = 192.168.1.2
verbose = True
network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
[baremetal]
[cells]
[cinder]
[conductor]
[ephemeral_storage_encryption]
[glance]
host = controller
[hyperv]
[image_file_url]
[ironic]
[keymgr]
[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = nova
admin_password = redhat
[libvirt]
[matchmaker_redis]
[matchmaker_ring]
[metrics]
[neutron]
url = http://controller:9696
auth_strategy = keystone
admin_auth_url = http://controller:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = redhat 
[osapi_v3]
[rdp]
[serial_console]
[spice]
[ssl]
[trusted_computing]
[upgrade_levels]
[vmware]
[xenserver]
[zookeeper]

output of file - /etc/neutron/neutron.conf

[DEFAULT]
verbose = True
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = guest
auth_strategy = keystone
core_plugin = m12
service_plugins = router
allow_overlapping_ips = True
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://controller:8774/v2
nova_admin_auth_url = http://controller:35357/v2.0
nova_region_name = regionOne
nova_admin_username = nova
nova_admin_tenant_id = aebbee0834764d4e9c8ace747f1dc81a
nova_admin_password = redhat
[matchmaker_redis]
[matchmaker_ring]
[quotas]
[agent]
[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = neutron
admin_password = redhat
[database]
connection = mysql://neutron:redhat@controller/neutron
[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
service_provider=VPN:openswan:neutron.services.vpn.service_drivers.ipsec.IPsecVPNDriver:default

Please let me know i am stuck at this point and cant move any further.

Thank, Tuxfux

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-21 14:25:58 -0500

Tuxfux gravatar image

Hi all,

I got the issue for the error. It was typo error.

Error: I gave "1" -> one instead of "L" , lower case

[root@controller neutron]# cat /etc/neutron/neutron.conf |grep -i ml2
core_plugin = m12

Correction:

[root@controller neutron]# cat /etc/neutron/neutron.conf |grep -i ml2
core_plugin = ml2

Thanks, tuxfux

edit flag offensive delete link more
0

answered 2015-09-18 12:44:06 -0500

I see this happen when I add "fwaas" to the service_plugins list in /etc/neutron/neutron.conf.

I note that I'm using puppet-openstack, the neutron module, and this should be handled in the neutron::services::fwaas class, but something about it isn't right.

edit flag offensive delete link more

Comments

But in the document its stated service_plugins = router . Did i miss anything ?

Tuxfux gravatar imageTuxfux ( 2015-09-18 13:45:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-09-18 07:18:08 -0500

Seen: 891 times

Last updated: Sep 21 '15