Ask Your Question
0

HTTP 401 error for authentication token from the Identity version 2.0 API

asked 2015-09-16 20:40:33 -0600

sgandhi gravatar image

While installing Kilo on 14.04, I am unable to get the authentication token from the Identity version 2.0 API, as mentioned in the 3rd step of these docs: http://docs.openstack.org/kilo/install-guide/install/apt/content/keystone-verify.html (http://docs.openstack.org/kilo/instal...)

controller@controller:~$ openstack --os-auth-url http://controller:35357 --os-project-name admin --os-username admin --os-auth-type password token issue.

Password: admin-password

ERROR: openstack The request you have made requires authentication. (HTTP 401) (Request-ID: req-ecffaa50-76c4-41fb-8068-784fdf882ba7)

I tried setting OS_USERNAME = admin; OS_PASSWORD = admin-password>; OS_TENANT_NAME=admin and OS_AUTH_URL=http://10.0.0.11:35357/v2. The error still persists.

Please tell me what am I doing wrong here?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-09-17 01:20:47 -0600

soumitrakarmakar gravatar image

You need to start the openstack-keystone service and disable it on the wsgi. This is an issue in kilo.

"Hope Persistent Systems learns from it"

edit flag offensive delete link more

Comments

Uncomment the ports in /etc/httpd/conf.d/wsgi-keystone.conf

soumitrakarmakar gravatar imagesoumitrakarmakar ( 2015-09-17 01:22:23 -0600 )edit

kindly please to be more clarify which port or line at wsgi config file i have to uncomment

Regards,

Hosam gravatar imageHosam ( 2015-09-17 01:37:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-09-16 20:40:33 -0600

Seen: 228 times

Last updated: Sep 17 '15