Cannot create instance vmware

asked 2015-09-16 02:55:05 -0600

wimbo gravatar image

Hi,

we already successfully to upload image, the image store in datastore (ESXi), means that the glance already configure to store the image to datastore-vmware through cinder, we can see the image on datastore that located on openstack_glance folder. But when we want to create instance, it will fail (error). we found errror like below on nova-compute.log

FileNotFoundException: File [datastore1]
172.16.0.103_base/38a7f44a-8fde-43fd-86e6-459924a91e7e was not found

why nova-compute not see to datastore? it seem that the instance fail because of nova-compute try to see the image in file mode.

Here is my nova.conf on my compute server

[DEFAULT]
network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth0
public_interface = eth0
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
rabbit_host = ddi-controller01
rabbit_password = PASSWORD
auth_strategy = keystone
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 172.16.0.101
novncproxy_base_url = http://ddi-controller01:6080/vnc_auto.html
instance_usage_audit = True
instance_usage_audit_period = hour
notify_on_state_change = vm_and_task_state
notification_driver = messagingv2
glance_api_servers=172.16.0.101:9292
image_service=nova.image.glance.GlanceImageService

[vmware]
host_ip=10.0.10.5
host_username=root
host_password=PASSWORD
cluster_name=Lab
datastore_regex=datastore1

[glance]
host = ddi-controller01

[paste_deploy]
flavor = keystone

[keystone_authtoken]
auth_uri = http://ddi-controller01:5000/v2.0
identity_uri = http://ddi-controller01:35357
admin_tenant_name = service
admin_user = nova
admin_password = PASSWORD

Here is by nova-compute.conf

[DEFAULT]
compute_driver=vmwareapi.VMwareVCDriver

[vmware]
host_ip=10.0.10.5
host_username=root
host_password=vmware
cluster_name=Lab
datastore_regex=datastore1

Thanks Wimbo

edit retag flag offensive close merge delete

Comments

Hi, I'm having the exact same issue after the environment been up for a year. Did you find an answer? Thanks

DRUMDUDESAN gravatar imageDRUMDUDESAN ( 2017-01-03 12:51:41 -0600 )edit