Ask Your Question

Unable to install Keystone

asked 2013-12-05 06:21:11 -0600

varsha gravatar image

updated 2013-12-05 08:07:58 -0600

rahmu gravatar image

The following error is thrown while trying to execute keystone user-list command

keystone error-for keystone user-list
No handlers could be found for logger "keystoneclient.client"
An unexpected error prevented the server from fulfilling your request. (OperationalError) (1045, "Access denied for user 'keystone'@'localhost' (using password: YES)") None None (HTTP 500)

and also says:

usage: keystone [--os_username <auth-user-name>]
                [--os_password <auth-password>]
                [--os_tenant_name <auth-tenant-name>]
                [--os_tenant_id <tenant-id>] [--os_auth_url <auth-url>]
                [--os_region_name <region-name>]
                [--os_identity_api_version <identity-api-version>]
                [--token <service-token>] [--endpoint <service-endpoint>]
                [--username <auth-user-name>] [--password <auth-password>]
                [--tenant_name <tenant-name>] [--auth_url <auth-url>]
                [--region_name <region-name>]
keystone: error: argument --username: expected one argument

Please help me in this regard.

edit retag flag offensive close merge delete


We're going to need more info about how you're installing Keystone and possibly extracts from the log, for us to give you any meaningful answer.

rahmu gravatar imagerahmu ( 2013-12-05 08:08:54 -0600 )edit

i am going through the steps given in install openstack on ubuntu 12.04 in 10 minutes from the link: (

varsha gravatar imagevarsha ( 2013-12-05 09:26:42 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2013-12-05 08:27:28 -0600

dheeru gravatar image

updated 2013-12-05 09:24:36 -0600

Please look at you /var/log/keystone/keystone.log. It should be failing to login for mysql db. If this is the case please do the following. There is a way to fix this db issue. Instead of doing this, it is better to start a fresh.

Please do all the steps without fail.

1. mysql -u root -p.  It will ask for password  and enter the right password
2. drop database keystone;

3. /etc/mysql/my.cnf and set the bind-address to the internal IP address of the controller
    e.g bind_address =

4. Follow the steps #2,3,4 and 5 in following link
5. if you still have problem do ping me.
edit flag offensive delete link more


Thanks for replying.i tried following all the steps u listed.while executing 2nd step it shows following error ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'keystone' at line 1

varsha gravatar imagevarsha ( 2013-12-05 09:18:05 -0600 )edit

my bad. How to drop the database keystone ? Use the following command. drop database keystone;

dheeru gravatar imagedheeru ( 2013-12-05 09:24:19 -0600 )edit

Did you try and is it working ? Please let me know. If it has solved, I will close your request.

dheeru gravatar imagedheeru ( 2013-12-06 02:47:19 -0600 )edit

after following the steps provided in the link its giving error at this command keystone-manage db_sync; ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'keystone-manage db_sync' at line 1

varsha gravatar imagevarsha ( 2013-12-06 03:44:36 -0600 )edit

this some syntax issue. You should be able to correct it by yourself.

dheeru gravatar imagedheeru ( 2013-12-06 04:15:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-12-05 06:21:11 -0600

Seen: 1,901 times

Last updated: Dec 05 '13