glance image-create Token Required

asked 2015-09-07 06:23:38 -0600

Naresh gravatar image

When I try to create a glance image gives output as a "Token Required".

Could you please help me with this.

controller ~]# glance --os-endpoint-type internal image-create --name "cirros 0.3.4 x86_64" --file cirros-0.3.3-x86_64-disk.img --disk-format qcow2 --container-format bare --progress

Token Required

Please validate the glance-api.conf and glance-registry.conf files.

controller ~]# grep ^[^#] /etc/glance/glance-api.conf

[DEFAULT]

verbose=True

notification_driver = noop

[database]

connection=mysql://glance:openstack@controller/glance

[keystone_authtoken]

auth_uri = http://controller:5000/v2.0

identity_uri = http://controller:35357

admin_tenant_name = service

admin_user = glance

admin_password = openstack

auth_host =127.0.0.1

[paste_deploy]

flavor= keystone

[store_type_location_strategy]

[profiler]

[task]

[glance_store]

default_store = file

filesystem_store_datadir = /var/lib/glance/images/

controller ~]# grep ^[^#] /etc/glance/glance-registry.conf

[DEFAULT]

verbose=True

notification_driver = noop

[database]

connection=mysql://glance:openstack@controller/glance

[keystone_authtoken]

auth_uri = http://controller:5000/v2.0

identity_uri = http://controller:35357

admin_tenant_name = service

admin_user = glance

admin_password = openstack

auth_host =127.0.0.1

[paste_deploy]

flavor=keystone

[profiler]

Please let me know what needs to be done.

edit retag flag offensive close merge delete