Ask Your Question

OpenStack service create fails on CentOS 7 with kilo release

asked 2015-09-02 15:25:12 -0500

donaldmize gravatar image

updated 2015-09-03 16:32:58 -0500

I followed the install manual, setting up keystone and httpd wsgi config files per the manual. The db sync for the keystone database worked, no errors in the logs.

But now when I do the below I get this:

 [root@anders-38 httpd]# openstack service create --name keystone --description "OpenStack Identity" identity
ERROR: openstack 'NoneType' object has no attribute '__getitem__'

I don't see any issues in the Apache or keystone logs. Everything looks fine there.

I get a lot of puzzling output with the --debug flag. It is like it is going to the internet or trying to go there for something. My machines IP is, but I see references to 16.85.x.x. It should not be going there. Any ideas?

Also, I'm using the openstack keystone client that goes thru the httpd webserver. Should I not be doing this?

DEBUG: openstackclient.common.clientmanager Get auth_ref DEBUG: openstackclient.identity.v2_0.service.CreateService take_action(Namespace(columns=[], description='OpenStack Identity', formatter='table', max_width=0, name='keystone', prefix='', type=None, type_or_name='identity', variables=[])) DEBUG: openstackclient.identity.client Instantiating identity client: DEBUG: keystoneclient.session REQ: curl -g -i -X POST http://localhost:35357/v2.0/OS-KSADM/... -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}b521caa6e1db82e5a01c924a419870cb72b81635" -d '{"OS-KSADM:service": {"type": "identity", "name": "keystone", "description": "OpenStack Identity"}}' INFO: requests.packages.urllib3.connectionpool Starting new HTTP connection (1): DEBUG: requests.packages.urllib3.connectionpool "POST http://localhost:35357/v2.0/OS-KSADM/... HTTP/1.1" 301 None DEBUG: keystoneclient.session RESP: [301] connection: Close location: server: BlueCoat-Security-Appliance RESP BODY: Redirection



INFO: requests.packages.urllib3.connectionpool Resetting dropped connection:

edit retag flag offensive close merge delete


Can you add --debug option between openstack and service. Share the output?. Also if you see any errors in /var/log/keystone/ share it too. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-09-02 16:54:48 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-09-04 14:28:33 -0500

donaldmize gravatar image

I had http_proxy and https_proxy set in my environment. Once I removed those it worked!! AHHHHHH!!!!! :-)

edit flag offensive delete link more

answered 2015-09-03 07:59:08 -0500

soumitrakarmakar gravatar image

Check whether your keystone service is running or not!! systemctl status openstack-keystone, also is it in wsgi mode or you are using the daemon itself?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-09-02 15:25:12 -0500

Seen: 402 times

Last updated: Sep 04 '15