not able to connect instance neutron networking enabled

asked 2015-09-02 05:29:22 -0500

ravindert gravatar image

updated 2015-09-02 06:31:58 -0500

Hi All,

I have enabled the neutron networking and able to boot the instance , also the instance is getting the ip address automatically. But i am not able to ping and ssh it . Below is the rules and configuration i have made for it. So please suggest what i have to do to allow the networking work for the instance.

Please let me know if more info required.

[root@controller ~(keystone)]# nova list
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
| ID                                   | Name  | Status | Task State | Power State | Networks                           |
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
| 848ecad0-da0b-474f-bf71-379e2797c8bf | cloud | ACTIVE | -          | Running     | int_net=192.168.100.3, 172.0.0.102 |
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
[root@controller ~(keystone)]#


[root@controller ~(keystone)]# neutron net-list
+--------------------------------------+---------+-------------------------------------------------------+
| id                                   | name    | subnets                                               |
+--------------------------------------+---------+-------------------------------------------------------+
| 101ac2f6-99c8-41c2-8788-044ae0dbe789 | ext_net | f99c7984-5d66-4c5f-b17e-c4c9aec5ea4f 172.0.0.0/24     |
| 8a5b893e-7ea1-45cb-ae5f-aa0c8d7c33da | int_net | 24de6473-6984-471c-bdd7-477c9b02198b 192.168.100.0/24 |
+--------------------------------------+---------+-------------------------------------------------------+
[root@controller ~(keystone)]#

configuration setting

/etc/neutron/plugins/ml2/ml2_conf.ini
# near line 64: add
[ml2_type_vlan]
network_vlan_ranges = physnet1:1000:2999
# add to the end
[ovs]
tenant_network_type = vlan
bridge_mappings = physnet1:br-eth1


[root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
HWADDR=08:00:27:60:0a:72
DEVICE=eth1
TYPE=Ethernet
ONBOOT=yes
PROMISC=yes
BRIDGE=br-eth1
[root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth2
HWADDR=08:00:27:03:20:36
DEVICE=eth2
TYPE=Ethernet
ONBOOT=yes
PROMISC=yes
BRIDGE=br-ext
[root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-ext
DEVICE=br-ext
TYPE=Bridge
BOOTPROTO=dhcp
#BOOTPROTO=static
#IPADDR=10.0.0.65
#NETMASK=255.255.255.0
ONBOOT=yes
[root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-eth1
DEVICE=br-eth1
TYPE=Bridge
BOOTPROTO=dhcp
#BOOTPROTO=static
#IPADDR=192.168.100.45
#NETMASK=255.255.255.0
ONBOOT=yes
[root@controller ~(keystone)]#

[root@controller ~(keystone)]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/32 scope link lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:0d:97:ec brd ff:ff:ff:ff:ff:ff
    inet 10.11.138.75/24 brd 10.11.138.255 scope global dynamic eth0
       valid_lft 863428sec preferred_lft 863428sec
    inet 10.0.0.249/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet 10.0.0.250/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet 10.0.0.251/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet 10.0.0.252/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe0d:97ec/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000
    link/ether 08:00:27:60:0a:72 brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000
    link/ether 08:00:27:03:20:36 brd ff:ff:ff:ff:ff ...
(more)
edit retag flag offensive close merge delete

Comments

Check security groups rules, if you have not modify it, by default pinging or sshing is disabled.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-09-02 06:34:34 -0500 )edit

Hi, I have already enabled the security group for ping and ssh.

[[root@controller ~(keystone)]# neutron security-group-rule-list  |grep 22
| 0529548f-dc01-4904-a470-19615bee7982 | default        | ingress   | IPv4      | 22/tcp        | 0.0.0.0/0 (CIDR) |
[root@controller ~(keystone)]# neutron secu
ravindert gravatar imageravindert ( 2015-09-02 06:53:21 -0500 )edit

best way to trace out such issues and get the feasible solution easily is to verify the packet flow uaing tcpdump. check that and share the results.... that will help to trace down the problem.

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-10-01 06:17:00 -0500 )edit