Ask Your Question
0

Account HEAD failed 503 Internal Server Error

asked 2013-12-04 12:22:17 -0500

Vignesh MPN gravatar image

updated 2013-12-06 16:18:57 -0500

smaffulli gravatar image

I am configuring Swift per the instructions in https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html-single/Installation_and_Configuration_Guide/index.html#chap-Installing_the_OpenStack_Object_Storage_Service

After completing configuration, I am getting a 503 internal server error while validating installation using "swift stat"

> Message from syslogd@localhost at Dec
> 4 09:29:34 ...  ?<131>proxy-server
> Account HEAD returning 503 for [507]
> (txn:
> tx62353887227d445fad636dbdda582119)
> (client_ip: 127.0.0.1)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:35 ...  ?<135>proxy-server
> Node error limited 127.0.0.1:6002
> (sdb1) (txn:
> tx88716d69ada741d1aecdec79cd7dc28e)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:35 ...  ?<131>proxy-server
> Account HEAD returning 503 for []
> (txn:
> tx88716d69ada741d1aecdec79cd7dc28e)
> (client_ip: 127.0.0.1)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:37 ...  ?<135>proxy-server
> Node error limited 127.0.0.1:6002
> (sdb1) (txn:
> txbe9692dc2d6042b2b07de156c65db6ff)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:37 ...  ?<131>proxy-server
> Account HEAD returning 503 for []
> (txn:
> txbe9692dc2d6042b2b07de156c65db6ff)
> (client_ip: 127.0.0.1)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:41 ...  ?<135>proxy-server
> Node error limited 127.0.0.1:6002
> (sdb1) (txn:
> tx652a3f07adb54517a6070ff35434dedc)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:41 ...  ?<131>proxy-server
> Account HEAD returning 503 for []
> (txn:
> tx652a3f07adb54517a6070ff35434dedc)
> (client_ip: 127.0.0.1)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:49 ...  ?<135>proxy-server
> Node error limited 127.0.0.1:6002
> (sdb1) (txn:
> tx16b1fcbc6a18472bae28840b15bfacac)
> 
> Message from syslogd@localhost at Dec
> 4 09:29:49 ...  ?<131>proxy-server
> Account HEAD returning 503 for []
> (txn:
> tx16b1fcbc6a18472bae28840b15bfacac)
> (client_ip: 127.0.0.1)
> 
> Message from syslogd@localhost at Dec
> 4 09:30:05 ...  ?<135>proxy-server
> Node error limited 127.0.0.1:6002
> (sdb1) (txn:
> tx39d798d702334ebb80bd4a1d1683af07)
> 
> Message from syslogd@localhost at Dec
> 4 09:30:05 ...  ?<131>proxy-server
> Account HEAD returning 503 for []
> (txn:
> tx39d798d702334ebb80bd4a1d1683af07)
> (client_ip: 127.0.0.1) Account HEAD
> failed:
> http://localhost:8080/v1/AUTH_2dd248ff7c05446b801eba44c082c133
> 503 Internal Server Error

I checked all the similar questions in this forum, but nothing works.

I checked the port in both account-server.conf and also the rings. Everything looks good. I tried tempauth and got the same error.

Following are my ports in conf and ring:

[DEFAULT]
devices = /srv/node/1
bind_ip = 127.0.0.1
bind_port = 6002
workers = 2

# swift-ring-builder /etc/swift/account.builder search /sdb1
Devices: id region zone ip address port name weight partitions balance meta
             0 1 1 127.0.0.1 6002 sdb1 1.00 786432 0.00

I am not able to turn on DEBUG log for the account-server as well. This is the only log I got from the account-server log (is it a 507 error?):

> Dec 4 09:29:34 localhost
> account-server 127.0.0.1 - -
> [04/Dec/2013:14:29:34 +0000] "HEAD
> /sdb1/23746/AUTH_2dd248ff7c05446b801eba44c082c133"
> 507 -
> "tx62353887227d445fad636dbdda582119"
> "-" "-" 0.0003 ""

Following is my log setting for account-server.conf

[app:account-server]
use = egg:swift#account
set log_level = DEBUG
set log_name = account-server
set log_facility = LOG_LOCAL0

Probably debug logs will help me troubleshoot the root cause better.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-12-06 18:42:28 -0500

torgomatic gravatar image

The error limiting indicates that the proxy can't contact the account servers. Make sure that the account server processes are all running and connectable from the proxy host.

edit flag offensive delete link more
0

answered 2014-07-10 12:39:52 -0500

DeepVish gravatar image

Please try changing the bind_ip from 127.0.0.1 to 0.0.0.0 in following files and then restart the all swift storage services.

account-server.conf: bind_ip = 0.0.0.0

container-server.conf: bind_ip = 0.0.0.0

object-server.conf: bind_ip = 0.0.0.0

Hope this solve your problem

edit flag offensive delete link more

Comments

I hit this "Account HEAD failed" issue too, and this problem gone after I set bind_ip to 0.0.0.0. Thanks a lot for your comments.

IBM_ZongQiang ZHANG gravatar imageIBM_ZongQiang ZHANG ( 2014-08-25 01:53:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-12-04 12:22:17 -0500

Seen: 1,653 times

Last updated: Jul 10 '14