socket.error 111 connection refused

asked 2015-08-28 16:03:44 -0500

knoesisboss gravatar image

Hi all,

Please excuse my limited knowledge with openstack. I took over this position a few months back and this openstack environment was already setup. I am running openstack 5.1(icehouse) deployed with fuel 5.1. Until recently, I am unable to access my newly created VMs. The environment seems to be running fine, I am able to create new VMs, and I can associate floating IPs but I am unable to login to them using the cloud key created. when I create a VM I noticed it outputs the error below then after a few minutes it returnt to the ubuntu login: but I am unable to ssh to my VM with my cloudkey.

Error on logs 2015-08-28 18:34:56,923 - url_helper.py[WARNING]: Calling 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [0/120s]: request error [HTTPConnectionPool(host='169.254.169.254', port=80): Max retries exceeded with url: /2009-04-04/meta-data/instance-id (Caused by <class 'socket.error'="">: [Errno 111] Connection refused)]

I have restarted all my openstack services several times, researched the inter for answers, but some of the answers I tried have not be helpful.

Any help would greatly be appreciated.

John

edit retag flag offensive close merge delete

Comments

John, it tells connection refused, so have you enabled the SSH access on VMs?

kumar lakshman kumar gravatar imagekumar lakshman kumar ( 2015-08-30 22:13:31 -0500 )edit

This is a issue with your metadata agent which cannot talk to the instance on the link-local ips. Try checking the error logs for your metadata agent and/or restart it. This means your key-pair will not be injected since the connection fails.

Tobias Urdin gravatar imageTobias Urdin ( 2015-08-31 08:58:27 -0500 )edit

Thanks Kumar, I was able to fix the issue by restarting my neutron-metadata service, as you suggested. Funny thing though, I had done that previously, without success.

knoesisboss gravatar imageknoesisboss ( 2015-09-01 08:37:04 -0500 )edit