Ask Your Question
1

Glance error in store configuration. Adding images to store is disabled. [closed]

asked 2015-08-28 08:20:19 -0500

ruben gravatar image

Hey!

I am pretty new to Openstack and I am experiencing a problem with adding images to Glance. When i try to add images to Glance i always get the following error:

410 Gone: Error in store configuration. Adding images to store is disabled. (HTTP N/A)

I reinstalled Openstack one time already and it spews out the same error. My storage settings in glance-api.conf is the following:

# Which backend scheme should Glance use by default is not specified
# in a request to add a new image to Glance? Known schemes are determined
# by the stores option.
# Deprecated group/name - [DEFAULT]/default_store
# Default: 'file'
default_store=file

# ============ Filesystem Store Options ========================

# Directory that the Filesystem backend store
# writes image data to
filesystem_store_datadir= /var/lib/glance/images/

The glance log when i try to add an image:

  2015-08-28 15:15:32.606 2617 INFO eventlet.wsgi.server [req-e7d95717-eeea-4f1c-a4b5-4281f3b9d588 3c71e0180f0945b4bd75247de663bbdf d413cb62f08c416d808defdb6cb0396f - - -] 127.0.0.1 - - [28/Aug/2015 15:15:32] "GET /v2/schemas/image HTTP/1.1" 200 4086 0.268775
2015-08-28 15:15:52.748 2623 INFO eventlet.wsgi.server [req-1906f528-792a-465a-a0e2-e9c8385519e6 3c71e0180f0945b4bd75247de663bbdf d413cb62f08c416d808defdb6cb0396f - - -] 127.0.0.1 - - [28/Aug/2015 15:15:52] "GET /v2/schemas/image HTTP/1.1" 200 4086 0.339106
2015-08-28 15:15:52.755 2623 INFO eventlet.wsgi.server [req-ed489c79-cdce-4268-99af-228341362289 3c71e0180f0945b4bd75247de663bbdf d413cb62f08c416d808defdb6cb0396f - - -] 127.0.0.1 - - [28/Aug/2015 15:15:52] "GET /v2/schemas/image HTTP/1.1" 200 4086 0.003279
2015-08-28 15:15:53.018 2623 INFO eventlet.wsgi.server [req-53e0ddfc-effa-4834-9b24-384c0a996c4a 3c71e0180f0945b4bd75247de663bbdf d413cb62f08c416d808defdb6cb0396f - - -] 127.0.0.1 - - [28/Aug/2015 15:15:53] "POST /v2/images HTTP/1.1" 201 858 0.177157
2015-08-28 15:15:53.171 2623 ERROR glance.api.v2.image_data [req-7ab5cf0b-a9b5-4334-8dc4-1795000aaf9d 3c71e0180f0945b4bd75247de663bbdf d413cb62f08c416d808defdb6cb0396f - - -] Error in store configuration. Adding images to store is disabled.
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data Traceback (most recent call last):
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data   File "/usr/lib/python2.7/site-packages/glance/api/v2/image_data.py", line 74, in upload
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data     image.set_data(data, size)
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data   File "/usr/lib/python2.7/site-packages/glance/domain/proxy.py", line 166, in set_data
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data     self.base.set_data(data, size)
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data   File "/usr/lib/python2.7/site-packages/glance/notifier.py", line 429, in set_data
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data     _send_notification(notify_error, 'image.upload', msg)
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 85, in __exit__
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data     six.reraise(self.type_, self.value, self.tb)
2015-08-28 15:15:53.171 2623 TRACE glance.api.v2.image_data   File "/usr/lib/python2.7/site-packages/glance/notifier.py", line 378, in set_data
2015-08-28 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ruben
close date 2015-08-31 08:04:14.475735

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-08-31 08:03:28 -0500

ruben gravatar image

Hey!

I fixed my own issue but I thought it would be helpful to post it under my own question so that people with the same error can resolve it trough this post. The trick that fixed my issue was commenting the "default_store" line as you can see below.

#default_store=file

After that i reloaded the database and rebooted.

edit flag offensive delete link more

Comments

Hi,

I experienced the same issue. But I found you can also keep default_store = file uncommented, but you have to uncomment the setting: stores = file,http too in that case:
stores = file,http
default_store = file

keesjank gravatar imagekeesjank ( 2015-12-30 04:29:31 -0500 )edit

one specific case. if you mount iscsi disk and disks couldn't be seen after reboot with any reason, glance disables it. so, please check your mounts at first iscsiadm -m node --login then restart the glance services in controller. watch the glance log for details under /var/log/glance/glance-api.

kunthar gravatar imagekunthar ( 2017-05-04 06:59:58 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-28 04:37:32 -0500

Seen: 8,439 times

Last updated: Aug 31 '15