keystone: error 500 when creating identity endpoint [closed]

asked 2015-08-27 00:59:39 -0600

pl33g0r gravatar image

updated 2015-08-28 02:05:39 -0600

Hi I am trying to setup a controller node on CentOS7 with OpenStack Kilo. When I am trying to add a new identity I am getting the following error:

openstack service create --name keystone --description "OpenStack Identity" identity
ERROR: openstack An unexpected error prevented the server from fulfilling your request. (HTTP 500) (Request-ID: req-7e2b16ee-7b9f-4432-9fe2-c5db33230c4f)

I was able to find logs but that still does not help yet...

2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi     context)
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/default.py", line 436, in do_execute
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi     cursor.execute(statement, parameters)
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/MySQLdb/cursors.py", line 174, in execute
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi     self.errorhandler(self, exc, value)
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi   File "/usr/lib64/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi     raise errorclass, errorvalue
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi ProgrammingError: (ProgrammingError) (1146, "Table 'keystone.service' doesn't exist") 'INSERT INTO service (id, type, enabled, extra) VALUES (%s, %s, %s, %s)' ('571300fc49d248fe8ef8c6be7aef2ac7', 'identity', 1, '{"name": "keystone", "description": "OpenStack Identity"}')
2015-08-27 23:36:50.388 1933 TRACE keystone.common.wsgi
2015-08-27 23:36:50.392 1933 INFO eventlet.wsgi.server [-] 10.17.6.2 - - [27/Aug/2015 23:36:50] "POST /v2.0/OS-KSADM/services HTTP/1.1" 500 381 0.028239
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2015-08-27 09:58:47.751732

Comments

search this site as there are multiple similar questions. Read https://ask.openstack.org/faq

smaffulli gravatar imagesmaffulli ( 2015-08-27 09:59:15 -0600 )edit

FYI this is not a duplicate all questions related to this issue are not resolved so I am not sure why my question was closed.

pl33g0r gravatar imagepl33g0r ( 2015-08-27 12:37:24 -0600 )edit

The question not only is a duplicate but lacks details. Vote up and comment on any of the other similar questions to make them appear on front page or ask a question providing enough debugging details to make it unique

smaffulli gravatar imagesmaffulli ( 2015-08-27 13:16:51 -0600 )edit

So instead of pointing new users into right directions you just simply close my request w/o any explanations (great first impression BTW)??? Additionally as first time OpenStack user, I do not know what debugging info I need to provide. It would be nice to know what exactly you are looking for...

pl33g0r gravatar imagepl33g0r ( 2015-08-27 13:40:00 -0600 )edit

That's why I suggest you to search this site first: there are lots of examples of what other people have been asked to provide, like extracts from logs, type of installations (devstack or distro packages or ...) Also https://ask.openstack.org/en/question...

smaffulli gravatar imagesmaffulli ( 2015-08-27 14:56:41 -0600 )edit