Ask Your Question
0

Openvswitch problems after upgrade

asked 2015-08-25 15:54:19 -0500

uffe gravatar image

updated 2015-08-27 05:23:04 -0500

Hi

I just did an yum upgrade and rebooted (everything worked perfectly before with gre). After that openvswitch won't create the gre tunnels.

My config is the same as before and a copy of the official documentation.

2015-08-25 22:49:17.612 7644 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-67cf0cd5-306f-4a13-8cce-d6ce62667d1e ] Cannot provision gre network for net-id=0c5dcf7a-47d2-4a2e-b82b-b4d39b363342 - tunneling disabled

2015-08-25 22:49:18.489 7644 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-67cf0cd5-306f-4a13-8cce-d6ce62667d1e ] Cannot provision flat network for net-id=163b2e4e-e471-4fec-a34b-9ceecd50f332 - no bridge for physical_network external

Ideas on where to start?

edit retag flag offensive close merge delete

Comments

Please, be more descriptive

1. Which OS are you running ?
2. Which Openstack release (s) ?
3. Which OVS versions involved ?
dbaxps gravatar imagedbaxps ( 2015-08-25 16:16:07 -0500 )edit

I'm running Centos 7.1

Openstack kilo release

openstack-neutron-openvswitch-2015.1.1-1.el7

openvswitch-2.3.1-2.el7.x86_64

uffe gravatar imageuffe ( 2015-08-25 17:50:44 -0500 )edit

Is it neutron or nova networking ?

dbaxps gravatar imagedbaxps ( 2015-08-26 01:52:55 -0500 )edit

It is neutron network

uffe gravatar imageuffe ( 2015-08-26 07:27:14 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-08-26 08:49:03 -0500

dbaxps gravatar image

updated 2015-08-26 09:18:52 -0500

Most probably your /etc/neutron/plugins/ml2/ml2_conf.ini is missing sections for [ovs] and [agent]
View : http://docs.openstack.org/kilo/instal...
In the [ovs] section, enable tunnels, configure the local tunnel endpoint, and map the external flat provider network to the br-ex external network bridge:

[ovs]
...

local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS
bridge_mappings = external:br-ex

Replace INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with the 
IP address of the instance tunnels network interface on your network node.
In the [agent] section, enable GRE tunnels:


[agent]
    ...
tunnel_types = gre

Another option is to configure file :-
/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
for each node serving as GRE endpoint.

View also : https://ask.openstack.org/en/question...
Regarding second error , please post ovs-vsctl show after fixing first error.

edit flag offensive delete link more

Comments

I did some more testing and ovs actually seems to work the problem seems to be with iptables. If i stop firewalld my instances can use Internet. But floating ips dont work without iptables.

Ideas on how to troubleshoot iptables?

uffe gravatar imageuffe ( 2015-08-26 10:21:22 -0500 )edit

Standard RDO utility packstack automatically disables firewalld and enables and tune ipv4 iptables during any kind of RDO deployment. You may try start firewalld , service iptables save, stop firewalld, service iptables start. But, I am not sure it would help.

dbaxps gravatar imagedbaxps ( 2015-08-26 10:32:23 -0500 )edit
0

answered 2015-08-26 12:49:44 -0500

uffe gravatar image

I found it, the problem was the same solution as in this thread: https://ask.openstack.org/en/question/69126/instances-in-one-of-the-compute-nodes-cant-get-fixed-ip-address/ (https://ask.openstack.org/en/question...)

adding those 2 iptables command fixed it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-25 15:54:19 -0500

Seen: 469 times

Last updated: Aug 27 '15