Yet another flavor of vif_type=binding_failed

asked 2015-08-21 12:35:53 -0600

rodrigocastrillon gravatar image

Hello everyone... I am facing this problem for 5 work days, rebuilt my OpenStack setup 3 times already, and always get the same error. I am following the OpenStack install guide for Kilo on Ubuntu 14.04, but using Ubuntu Server 15.04 instead. My setup is in a VMware lab, in one physical host I created 3 VMs, 1 controller, 1 network and 1 compute node. My network node have 3 interfaces in 3 different vlans and one of them in a Public VLAN, while the other 2 nodes are connected only in Tunnels and Management VLANs. Right after finishing the installation of Horizon, when I try to spawn an instance on the Public network, it fails. Here is the /var/log/neutron/neutron-server.log from Controller node:

2015-08-21 12:00:00.555 19091 DEBUG neutron.plugins.ml2.drivers.mech_agent [req-e9b6a595-a134-446b-bd86-f8489fa626b0 ] Checking agent: {'binary': u'neutron-openvswitch-agent', 'description': None, 'admin_state_up': True, 'heartbeat_timestamp': datetime.datetime(2015, 8, 21, 14, 59, 47), 'alive': True, 'topic': u'N/A', 'host': u'BRHOITDOS03', 'agent_type': u'Open vSwitch agent', 'created_at': datetime.datetime(2015, 8, 21, 14, 25, 59), 'started_at': datetime.datetime(2015, 8, 21, 14, 28, 17), 'id': u'2bcf83af-49d3-4b6b-adc5-823834274f39', 'configurations': {u'in_distributed_mode': False, u'arp_responder_enabled': False, u'tunneling_ip': u'192.168.200.192', u'devices': 1, u'l2_population': False, u'tunnel_types': [u'gre'], u'enable_distributed_routing': False, u'bridge_mappings': {}}} bind_port /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/mech_agent.py:68

2015-08-21 12:00:00.556 19091 DEBUG neutron.plugins.ml2.drivers.mech_agent [req-e9b6a595-a134-446b-bd86-f8489fa626b0 ] Checking segment: {'segmentation_id': None, 'physical_network': u'external', 'id': u'1dfa8ccd-cd40-465e-887f-898dff87ede9', 'network_type': u'flat'} for mappings: {} with network types: [u'gre', 'local', 'flat', 'vlan'] check_segment_for_agent /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/mech_agent.py:182

2015-08-21 12:00:00.557 19091 DEBUG neutron.plugins.ml2.drivers.mech_agent [req-e9b6a595-a134-446b-bd86-f8489fa626b0 ] Network 1dfa8ccd-cd40-465e-887f-898dff87ede9 is connected to physical network external, but agent BRHOITDOS03 **reported physical networks {}**. The physical network must be configured on the agent if binding is to succeed. check_segment_for_agent /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/mech_agent.py:208

2015-08-21 12:00:00.557 19091 ERROR neutron.plugins.ml2.managers [req-e9b6a595-a134-446b-bd86-f8489fa626b0 ] Failed to bind port 6519be20-e902-4859-a295-116e57272035 on host BRHOITDOS03

This is the output of "ovs-vsctl show" executed in the Network node:

48cb666c-d09e-47ee-a865-3835ad1ee43e
    Bridge br-tun
        fail_mode: secure
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-c0a8c8c0"
            Interface "gre-c0a8c8c0"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.200.193", out_key=flow, remote_ip="192.168.200.192"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    Bridge br-int
        fail_mode: secure
        Port "qg-dcb4e741-4a"
            tag: 2
            Interface "qg-dcb4e741-4a"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port "qr-c00c4ee3-5f"
            tag: 1
            Interface "qr-c00c4ee3-5f"
                type: internal
        Port "tap482c273c-e7"
            tag: 1
            Interface "tap482c273c-e7"
                type: internal
    ovs_version: "2.3.1"

And the same command from the Compute node ... (more)

edit retag flag offensive close merge delete

Comments

I wondered if you had an answer to this issue. I have the same issue and I found that all qrouter related ports are down (tap,qg, qr) moreover, the port qg should be in br-ex not br-int as I read from the documents and as I saw from the digram. if you managed to solve this issue, please share.

Haifa Al Nasseri gravatar imageHaifa Al Nasseri ( 2016-03-08 06:46:17 -0600 )edit