Ask Your Question
0

network_type value 'flat' not supported when creating a new neutron network

asked 2015-08-21 08:14:50 -0500

BlackSpy21 gravatar image

updated 2015-08-21 08:20:02 -0500

Following the install guide for OpenStack on Juno, and when running:

 neutron net-create ext-net --router:external True --provider:physical_network external --provider:network_type flat

I get:

Invalid input for operation: network_type value 'flat' not supported. (HTTP 400) (Request-ID: req-2dd98c98-bffa-43b3-849b-788cbf470643)

I have checked my ml2_conf.ini file on the networking node and it includes the line:

type_drivers = flat,gre

My ml2.conf.ini file on my Controller node has the line:

type_drivers = local,gre,flat

Don't know where else to look. Can anyone advise as to where else I need to specify 'flat' to allow this command to work?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-08-21 08:25:48 -0500

BlackSpy21 gravatar image

For others:

Changed ml2.conf.ini on my controller node to have local at the back:

type_drivers = flat,gre,local

Then restarted neutron server

service neutron-server restart

That seemed to fix the problem.

edit flag offensive delete link more

Comments

this helped me to fix the issue in openstack mitaka

sibomarie gravatar imagesibomarie ( 2016-10-31 06:12:53 -0500 )edit
0

answered 2016-05-03 23:11:21 -0500

rahmed gravatar image

Enabling flat in ml2.conf.ini file resolved the issue

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-21 08:14:50 -0500

Seen: 4,403 times

Last updated: Aug 21 '15