Ask Your Question
1

Can´t do anything with glance. Authentication fails

asked 2015-08-20 08:01:55 -0500

Manuals gravatar image

updated 2015-08-26 07:54:47 -0500

Hey there,

I want to setup OpenStack with 4 Nodes(2 Compute Nodes). I followed the Documentation for Icehouse on Ubuntu 14.04. Now I´m at "5. Verify Image Service Installation" and if i try image-create or image-list glance return "Invalid OpenStack Identity credentials.". But Keystone-Commands working fine.

My Glance version is 0.19.0 an my Keystone verion is 1.6.0. For the keystoneclient i get a deprecation warning on each executed command.

Glance output:

glance -d image-list
curl -g -i -X GET -H 'Accept-Encoding: gzip, deflate' -H 'Accept: */*' -H 'User-Agent: python-glanceclient' -H 'Connection: keep-alive' -H 'X-Auth-Token: {SHA1}8da18f7e26486c085292b96afaf3b8d238a80e64' -H 'Content-Type: application/octet-stream' http://DKCTR001:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20
Request returned failure status 401.
Invalid OpenStack Identity credentials.

admin-openrc.sh:

export OS_USERNAME=admin
export OS_PASSWORD=30zX9CWiFWLL
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://DKCTR001:35357/v2.0

/var/log/glance/api.log:

2015-08-20 14:52:55.890 2704 WARNING keystoneclient.middleware.auth_token [-] Retrying on HTTP connection exception: [Errno 1] _ssl.c:510: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
2015-08-20 14:52:56.406 2704 WARNING keystoneclient.middleware.auth_token [-] Retrying on HTTP connection exception: [Errno 1] _ssl.c:510: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
2015-08-20 14:52:57.424 2704 WARNING keystoneclient.middleware.auth_token [-] Retrying on HTTP connection exception: [Errno 1] _ssl.c:510: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
2015-08-20 14:52:59.447 2704 ERROR keystoneclient.middleware.auth_token [-] HTTP connection exception: [Errno 1] _ssl.c:510: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
2015-08-20 14:52:59.447 2704 WARNING keystoneclient.middleware.auth_token [-] Authorization failed for token

/var/log/glance/registry.log:

2015-08-20 11:12:21.482 2192 WARNING keystoneclient.middleware.auth_token [-] This middleware module is deprecated as of v0.10.0 in favor of keystonemiddleware.auth_token - please update your WSGI pipeline to reference the new middleware package.
2015-08-20 11:12:21.483 2192 WARNING keystoneclient.middleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-08-20 11:12:21.483 2192 WARNING keystoneclient.middleware.auth_token [-] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint

/etc/glance/glance-api.conf:

[DEFAULT]
default_store = file
bind_host = 0.0.0.0
bind_port = 9292
log_file = /var/log/glance/api.log
backlog = 4096
workers = 1

registry_host = 0.0.0.0
registry_port = 9191
registry_client_protocol = http

rabbit_host = 172.19.1.1
rabbit_port = 5672
rabbit_use_ssl = false
rabbit_userid = guest
rabbit_password = eSwBjZUmTdOa
rabbit_virtual_host = /
rabbit_notification_exchange = glance
rabbit_notification_topic = notifications
rabbit_durable_queues = False

filesystem_store_datadir = /var/lib/glance/images/

swift_store_auth_version = 2
swift_store_auth_address = 127.0.0.1:5000/v2.0/
swift_store_user = jdoe:jdoe
swift_store_key = a86850deb2742ec3cb41518e26aa2d89
swift_store_container = glance
swift_store_create_container_on_put = False
swift_store_large_object_size = 5120
swift_store_large_object_chunk_size = 200
swift_enable_snet = False

s3_store_host = 127.0.0.1:8080/v1.0/
s3_store_access_key = <20-char AWS access key>
s3_store_secret_key = <40-char AWS secret key>
s3_store_bucket = <lowercased 20-char aws access key>glance
s3_store_create_bucket_on_put = False

sheepdog_store_address = localhost
sheepdog_store_port = 7000
sheepdog_store_chunk_size = 64

delayed_delete = False
scrub_time = 43200
scrubber_datadir = /var/lib/glance/scrubber

image_cache_dir = /var/lib/glance/image-cache/

[database]
connection = mysql://glance:MUPwByVwRRr8 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2015-08-20 16:50:43 -0500

updated 2015-09-01 02:43:02 -0500

Hi, auth_uri = http://DKCTR001:5000/v2.0 must be in both files, glance-api and glance-registry, restart both services and try again.

Update 1.

auth_uri replaces auth_host, auth_portand auth_protocol. Comment these lines and try again.

Update 2.

I found a similar issue: https://bugs.launchpad.net/glance/+bug/1398495

Here, he uncomment auth_protocol and keeps auth_hostand auth_port commented. Regards

edit flag offensive delete link more

Comments

Hey Eduardo, i did this changes but the Problem is still present. Is there another idea? Kind Regards

Manuals gravatar imageManuals ( 2015-09-01 02:21:25 -0500 )edit

Edited answer

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-09-01 02:39:48 -0500 )edit

Hey Eduardo, thank you very much for the fast reply. Unfortunately i have many things to do at this time. I will perform the changes you have noted as soon as possible.

And please excuse my very rusty english.

Kind Regards

Manuals gravatar imageManuals ( 2015-09-03 08:48:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-20 08:01:55 -0500

Seen: 1,359 times

Last updated: Sep 01 '15