Ask Your Question
1

configuring linuxbridge in ML2 Juno vif bind failed Device not defined on plugin

asked 2015-08-19 20:13:39 -0500

cpk gravatar image

updated 2015-08-19 20:42:55 -0500

smaffulli gravatar image

Hi, I am trying to convert a existing 3 Node openstack setup (Juno) with OpenVswitch to linuxbridge. One node has controller node and network node, the other two nodes are compute nodes. I changed ml2_conf.ini, nova.conf, neutron.conf,dhcp_agent.ini and l3_agent.ini to be linuxbridge driver. Then when I try to create external network and then the tenant network. I get in neutron/server.log the following errors (controller node)

/var/log/neutron/server.log

2015-08-19 17:39:21.491 5927 DEBUG neutron.plugins.ml2.drivers.mech_agent [req-87137cff-d8ac-4a0c-b64f-d1d5391ebd9a None] Checking agent: {'binary': u'neutron-linuxbridge-agent', 'description': None, 'admin_state_up': True, 'heartbeat_timestamp': datetime.datetime(2015, 8, 20, 0, 39, 1), 'alive': True, 'id': u'1063d081-c5fb-4b9e-b020-7eb1cb6de1e1', 'topic': u'N/A', 'host': u'ace99', 'agent_type': u'Linux bridge agent', 'started_at': datetime.datetime(2015, 8, 20, 0, 39, 1), 'created_at': datetime.datetime(2015, 8, 20, 0, 6, 44), 'configurations': {u'interface_mappings': {}, u'devices': 2}} bind_port /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/mech_agent.py:65
2015-08-19 17:39:21.492 5927 DEBUG neutron.plugins.ml2.drivers.mech_linuxbridge [req-87137cff-d8ac-4a0c-b64f-d1d5391ebd9a None] Checking segment: {'segmentation_id': None, 'physical_network': u'external', 'id': u'c7e01979-b976-4a43-9583-4481be2d40df', 'network_type': u'flat'} for mappings: {} with tunnel_types: [] check_segment_for_agent /usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/mech_linuxbridge.py:48
**2015-08-19 17:39:21.494 5927 WARNING neutron.plugins.ml2.managers [req-87137cff-d8ac-4a0c-b64f-d1d5391ebd9a None**] Failed to bind port 6ae175fe-bbd9-4002-a362-9a756e9ff0d4 on host ace99****
2015-08-19 17:39:21.494 5927 DEBUG neutron.openstack.common.lockutils [req-87137cff-d8ac-4a0c-b64f-d1d5391ebd9a None] Got semaphore "db-access" lock /usr/lib/python2.7/dist-packages/neutron/openstack/common/lockutils.py:168
2015-08-19 17:39:21.517 5927 WARNING neutron.plugins.ml2.plugin [req-87137cff-d8ac-4a0c-b64f-d1d5391ebd9a None] In _notify_port_updated(), no bound segment for port 6ae175fe-bbd9-4002-a362-9a756e9ff0d4 on network 387d0501-72d4-4688-8ef2-20031860e848"

neutron/linuxbridge-agent.log

In the linuxbridge agent log I see

2015-08-19 17:39:23.711 5849 DEBUG neutron.plugins.linuxbridge.agent.linuxbridge_neutron_agent [req-b8fa1e6c-8b5f-456b-901e-7a0efb825aa5 None] Port tap6ae175fe-bb added treat_devices_added_updated /usr/lib/python2.7/dist-packages/neutron/plugins/linuxbridge/agent/linuxbridge_neutron_agent.py:879
2015-08-19 17:39:23.712 5849 INFO neutron.plugins.linuxbridge.agent.linuxbridge_neutron_agent [req-b8fa1e6c-8b5f-456b-901e-7a0efb825aa5 None] Device tap6ae175fe-bb not defined on plugin

ml2_conf.ini (controller/network node)

[ml2]
type_drivers = flat,vlan
tenant_network_types = vlan
mechanism_drivers = linuxbridge
[ml2_type_flat]
flat_networks = external
[ml2_type_vlan]
network_vlan_ranges = external,external-vlan:1:500

[ml2_type_gre]
[ml2_type_vxlan]


[securitygroup]

enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

[ovs]

[linuxbridge]
local_ip = 172.16.99.1
physical_interface_mapping = external:eth1,external-vlan:eth1


[agent]

root@ace99:/home/acelio# sudo brctl show
bridge name     bridge id               STP enabled     interfaces
br-ex           8000.00259048a5f2       no              eth1
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-20 13:47:33 -0500

cpk gravatar image

I found the issue never got around to updating the thread. The issue was I had select the right interfaces in physical_interface_mapping, my external was eth1, while my data interface was p1p1. Also I had issue using Vlan 1 on ubuntu, ended up using vlans 2 onwards.

See below for the working config on controller


[ml2] type_drivers = flat,vlan tenant_network_types = vlan mechanism_drivers = linuxbridge [ml2_type_flat] flat_networks = external [ml2_type_vlan] network_vlan_ranges = vlan:2:1000

[ml2_type_gre]

[securitygroup]

enable_security_group = True enable_ipset = True firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

[ovs]

[linux_bridge] physical_interface_mappings = vlan:p1p1,external:eth1

[vlans] tenant_network_type = vlan network_vlan_ranges = vlan:2:1000

[vxlan] enable_vxlan = False l2_population = False local_ip = xx.xx.xx.xx

[agent]

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-19 20:13:39 -0500

Seen: 1,496 times

Last updated: Oct 20 '15